n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
CVE-2026-1470GHSA-5xrp-6693-jjx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.5.1, 2.4.5, 1.123.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.17>= 2.0.0, < 2.4.5>= 2.5.0, < 2.5.1
- Fixed in
- 2.4.5, 2.5.1, 1.123.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xrp-6693-jjx9 lists affected ranges: npm n8n >=0 =2.0.0 =2.5.0 <2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5xrp-6693-jjx9 lists affected ranges: npm n8n >=0 =2.0.0 =2.5.0 <2.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-1470: 20.40% estimated exploitation activity in the next 30 days; percentile 97.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
n8n contains a critical Remote Code Execution (RCE) vulnerability in its workflow Expression evaluation system. Expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5xrp-6693-jjx9
- Revision 2 · amended ·
Amended from osv record GHSA-5xrp-6693-jjx9
- Revision 1 · created ·
Published from ghsa record GHSA-5xrp-6693-jjx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1470 Advisory: n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution IDs: CVE-2026-1470, GHSA-5xrp-6693-jjx9 Record: https://patchnext.com/advisories/cve-2026-1470 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.5.1, 2.4.5, 1.123.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.17; >= 2.0.0, < 2.4.5; >= 2.5.0, < 2.5.1; fixed in 2.4.5, 2.5.1, 1.123.17 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5xrp-6693-jjx9 (GitHub-reviewed advisory GHSA-5xrp-6693-jjx9 lists affected ranges: npm n8n >=0 =2.0.0 =2.5.0 <2.5.1) - Verified: https://osv.dev/vulnerability/GHSA-5xrp-6693-jjx9 (OSV record GHSA-5xrp-6693-jjx9 lists affected ranges: npm n8n >=0 =2.0.0 =2.5.0 <2.5.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…