Skip to content

← Actionable
Medium, CVSS 5.3amended

webpack-dev-server vulnerable to denial of service via a malformed Host or Origin header

CVE-2026-14631GHSA-m28w-2pqf-7qgj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack-dev-server 5.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-14631: 0.52% estimated exploitation activity in the next 30 days; percentile 44.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unauthenticated peer that can reach the webpack-dev-server process can terminate it by sending either a normal HTTP request with a malformed Host header, or a WebSocket upgrade to the default /ws endpoint with a malformed Origin header. The malformed header triggers an uncaught exception in the host-validation path and crashes the dev server process. Patches Fixed in webpack-dev-server 5.2.6 by treating malformed Host and Origin header values as invalid rather than throwing (see PR #5699). Workarounds Keep the dev server bound to localhost (the default) and do not expose it to untrusted networks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m28w-2pqf-7qgj

  2. Revision 1 · created ·

    Published from osv record GHSA-m28w-2pqf-7qgj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-14631

Advisory: webpack-dev-server vulnerable to denial of service via a malformed Host or Origin header
IDs: CVE-2026-14631, GHSA-m28w-2pqf-7qgj
Record: https://patchnext.com/advisories/cve-2026-14631 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webpack-dev-server 5.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webpack-dev-server: affected <= 5.2.5; fixed in 5.2.6

## Suggested inspection (read-only)
- `npm ls webpack-dev-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webpack-dev-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m28w-2pqf-7qgj (OSV record GHSA-m28w-2pqf-7qgj lists affected ranges: npm webpack-dev-server >=0 <5.2.6 (fixed))
- Verified: https://github.com/advisories/GHSA-m28w-2pqf-7qgj (GitHub-reviewed advisory GHSA-m28w-2pqf-7qgj lists affected ranges: npm webpack-dev-server >=0 <=5.2.5)

Commands are suggestions: review each one before running it.

Loading voting…