Skip to content

← Actionable
Medium, CVSS 4.7amended

webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints

CVE-2026-14620GHSA-f5vj-f2hx-8m93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack-dev-server 5.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
EPSS
  • CVE-2026-14620: 0.52% estimated exploitation activity in the next 30 days; percentile 44.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The internal /webpack-dev-server/open-editor and /webpack-dev-server/invalidate endpoints perform state-changing actions on any GET request, without verifying that the request originated from the dev server's own page. Any website a developer visits while the dev server is running can trigger them cross-origin with no interaction beyond the visit. An attacker can open an arbitrary existing local file in the developer's editor, including files outside the project root (e.g. ~/.ssh/config). The file's contents are not returned to the attacker. Repeated requests can also spawn editor processes and force recompilations, degrading the developer's machine. Patches Fixed in webpack-dev-server 5.2.6 by rejecting cross-site requests to the /webpack-dev-server/open-editor and /webpack-dev-server/invalidate endpoints (see PR #5698). Workarounds None

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f5vj-f2hx-8m93

  2. Revision 1 · created ·

    Published from osv record GHSA-f5vj-f2hx-8m93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-14620

Advisory: webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints
IDs: CVE-2026-14620, GHSA-f5vj-f2hx-8m93
Record: https://patchnext.com/advisories/cve-2026-14620 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webpack-dev-server 5.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webpack-dev-server: affected <= 5.2.5; fixed in 5.2.6

## Suggested inspection (read-only)
- `npm ls webpack-dev-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webpack-dev-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f5vj-f2hx-8m93 (OSV record GHSA-f5vj-f2hx-8m93 lists affected ranges: npm webpack-dev-server >=0 <5.2.6 (fixed))
- Verified: https://github.com/advisories/GHSA-f5vj-f2hx-8m93 (GitHub-reviewed advisory GHSA-f5vj-f2hx-8m93 lists affected ranges: npm webpack-dev-server >=0 <=5.2.5)

Commands are suggestions: review each one before running it.

Loading voting…