brace-expansion: DoS via unbounded expansion length causing an out-of-memory process crash
CVE-2026-14257GHSA-mh99-v99m-4gvg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (brace-expansion 5.0.8, 3.0.3, 2.1.3, 1.1.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm brace-expansion
- Affected
- >= 4.0.0, < 5.0.8>= 3.0.0, < 3.0.3>= 2.0.0, < 2.1.3< 1.1.17
- Fixed in
- 2.1.3, 1.1.17, 3.0.3, 5.0.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mh99-v99m-4gvg lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mh99-v99m-4gvg lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-14257: 0.64% estimated exploitation activity in the next 30 days; percentile 50.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary expand() bounds the number of results it produces (the max option, 100000 by default) but not their length. By chaining many brace groups, an attacker keeps the result count under max while making every result grow with the number of groups. Building max long results — plus the intermediate arrays combined at each brace group — exhausts memory and crashes the Node process with an uncatchable out-of-memory error. try/catch around expand() does not help: the fatal error terminates the process. A ~7.5 KB input ('{a,b}'.repeat(1500)) is enough to crash a default Node process. Details For N chained brace groups such as '{a,b}'.repeat(N): - the result count is 2^N, immediately capped at max (100000), so the max protection appears to hold, but - each result is N characters long, so the total output size is max × N characters, which grows without bound in N. expand combines each brace set with the fully-expanded tail: The loop guard expansions.length < max limits how many strings are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mh99-v99m-4gvg
- Revision 1 · created ·
Published from osv record GHSA-mh99-v99m-4gvg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-14257 Advisory: brace-expansion: DoS via unbounded expansion length causing an out-of-memory process crash IDs: CVE-2026-14257, GHSA-mh99-v99m-4gvg Record: https://patchnext.com/advisories/cve-2026-14257 (revision 2, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: brace-expansion 5.0.8, 3.0.3, 2.1.3, 1.1.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm brace-expansion: affected >= 4.0.0, < 5.0.8; >= 3.0.0, < 3.0.3; >= 2.0.0, < 2.1.3; < 1.1.17; fixed in 2.1.3, 1.1.17, 3.0.3, 5.0.8 ## Suggested inspection (read-only) - `npm ls brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on brace-expansion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mh99-v99m-4gvg (OSV record GHSA-mh99-v99m-4gvg lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.17 (fixed)) - Verified: https://github.com/advisories/GHSA-mh99-v99m-4gvg (GitHub-reviewed advisory GHSA-mh99-v99m-4gvg lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.17) Commands are suggestions: review each one before running it.
Loading voting…