Skip to content

← Actionable
Medium, CVSS 6.8amended

AWS CLI: Overly permissive File Permissions

CVE-2026-13769GHSA-wfp6-f47h-hxc3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (awscli 1.44.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI awscli

    Affected
    <= 1.44.77
    Fixed in
    1.44.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-13769: 0.17% estimated exploitation activity in the next 30 days; percentile 6.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AWS Command Line Interface (AWS CLI) is a unified tool for managing AWS services from the command line. Certain CLI subcommands wrote credential and configuration files with world-readable permissions on Unix-like systems with a default umask, allowing other local users on the same host to read credentials. Impact On Unix-like systems with a default umask, the following AWS CLI subcommands wrote credential or configuration files with world-readable permissions (0644) instead of owner-only (0600): - aws codeartifact login - aws iam create-virtual-mfa-device - aws deploy register Any other local user on the same host could read these files and obtain the credentials. Impacted versions: <=1.44.77 (v1) AND <=2.34.28 (v2) Patches This issue has been addressed in AWS CLI v1 version 1.44.78 and AWS CLI v2 version 2.34.29. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. If you have any questions or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wfp6-f47h-hxc3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wfp6-f47h-hxc3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-13769

Advisory: AWS CLI: Overly permissive File Permissions
IDs: CVE-2026-13769, GHSA-wfp6-f47h-hxc3
Record: https://patchnext.com/advisories/cve-2026-13769 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: awscli 1.44.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI awscli: affected <= 1.44.77; fixed in 1.44.78

## Suggested inspection (read-only)
- `python -m pip show awscli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on awscli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wfp6-f47h-hxc3 (OSV record GHSA-wfp6-f47h-hxc3 lists affected ranges: PyPI awscli >=0 <1.44.78 (fixed))
- Verified: https://github.com/advisories/GHSA-wfp6-f47h-hxc3 (GitHub-reviewed advisory GHSA-wfp6-f47h-hxc3 lists affected ranges: PyPI awscli >=0 <=1.44.77)

Commands are suggestions: review each one before running it.

Loading voting…