Skip to content

← Actionable
High, CVSS 7.4

undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives

CVE-2026-13697GHSA-4cwx-7wf7-3272

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.9.0, 7.29.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 7.0.0, < 7.29.0>= 8.0.0, < 8.9.0
    Fixed in
    8.9.0, 7.29.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2026-13697: 0.57% estimated exploitation activity in the next 30 days; percentile 47.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Two issues in undici's cache interceptor, both fixed by the same patch on lib/util/cache.js: 1. Shared-cache disclosure: Responses with malformed qualified Cache-Control: private directives such as private="" or private="," can be incorrectly stored in the default shared cache, then served to a later caller with the same cache key. 2. Parse-time crash: Mixed unqualified-and-qualified private directives in the same header (such as public, max-age=60, private, private="hdr") cause an uncaught TypeError in the cache-control parser, terminating the request. Impact Shared-cache disclosure Applications using interceptors.cache() in shared mode may cache a user-specific response and serve it to a later caller with the same cache key. This can disclose private response bodies and headers, including Set-Cookie. Required conditions: - the cache interceptor is enabled in shared mode, including the default configuration; - an upstream returns a malformed directive such as Cache-Control:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4cwx-7wf7-3272

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-13697

Advisory: undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives
IDs: CVE-2026-13697, GHSA-4cwx-7wf7-3272
Record: https://patchnext.com/advisories/cve-2026-13697 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.9.0, 7.29.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 7.0.0, < 7.29.0; >= 8.0.0, < 8.9.0; fixed in 8.9.0, 7.29.0

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4cwx-7wf7-3272 (GitHub-reviewed advisory GHSA-4cwx-7wf7-3272 lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.9.0)

Commands are suggestions: review each one before running it.

Loading voting…