fast-uri vulnerable to host confusion via failed IDN canonicalization
CVE-2026-13676GHSA-4c8g-83qw-93j6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.0.1, 3.1.3, 2.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- >= 4.0.0, < 4.0.1>= 3.0.0, < 3.1.3>= 2.3.1, < 2.4.2
- Fixed in
- 2.4.2, 3.1.3, 4.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4c8g-83qw-93j6 lists affected ranges: npm fast-uri >=4.0.0 =3.0.0 =2.3.1 <2.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c8g-83qw-93j6 lists affected ranges: npm fast-uri >=4.0.0 =3.0.0 =2.3.1 <2.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-13676: 0.69% estimated exploitation activity in the next 30 days; percentile 52.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri versions = 2.3.1, <= 4.0.0 fail to canonicalize Unicode/IDN hostnames for HTTP-family URLs. The IDN conversion path calls URL.domainToASCII(...) on the global WHATWG URL constructor, where that helper does not exist. The resulting TypeError is silently routed into parsed.error, but parse(), normalize(), and equal() all return with the host left in its original Unicode form. For example, http://127。0。0。1/ is treated by fast-uri as host 127。0。0。1, while Node's WHATWG URL parser and fetch() canonicalize the same input to 127.0.0.1. Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering, redirect validation, outbound proxy routing) before passing the same URL into Node's URL or fetch() consumers see a policy/use desync and can be steered to an unintended destination. Patches Upgrade to fast-uri v4.0.1, v3.1.3, or v2.4.2 Workarounds None. Upgrade to the patched version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4c8g-83qw-93j6
- Revision 1 · created ·
Published from osv record GHSA-4c8g-83qw-93j6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-13676 Advisory: fast-uri vulnerable to host confusion via failed IDN canonicalization IDs: CVE-2026-13676, GHSA-4c8g-83qw-93j6 Record: https://patchnext.com/advisories/cve-2026-13676 (revision 2, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.0.1, 3.1.3, 2.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected >= 4.0.0, < 4.0.1; >= 3.0.0, < 3.1.3; >= 2.3.1, < 2.4.2; fixed in 2.4.2, 3.1.3, 4.0.1 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4c8g-83qw-93j6 (OSV record GHSA-4c8g-83qw-93j6 lists affected ranges: npm fast-uri >=4.0.0 =3.0.0 =2.3.1 <2.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4c8g-83qw-93j6 (GitHub-reviewed advisory GHSA-4c8g-83qw-93j6 lists affected ranges: npm fast-uri >=4.0.0 =3.0.0 =2.3.1 <2.4.2) Commands are suggestions: review each one before running it.
Loading voting…