github.com/mattermost/mattermost/server/public vulnerable to path traversal in API route construction
CVE-2026-13426GHSA-72v2-v53v-4qmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/public 0.1.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/public
- Affected
- < 0.1.22
- Fixed in
- 0.1.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72v2-v53v-4qmm lists affected ranges: Go github.com/mattermost/mattermost/server/public >=0 <0.1.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-72v2-v53v-4qmm lists affected ranges: Go github.com/mattermost/mattermost/server/public >=0 <0.1.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-13426: 0.29% estimated exploitation activity in the next 30 days; percentile 21.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-72v2-v53v-4qmm
- Revision 1 · created ·
Published from ghsa record GHSA-72v2-v53v-4qmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-13426 Advisory: github.com/mattermost/mattermost/server/public vulnerable to path traversal in API route construction IDs: CVE-2026-13426, GHSA-72v2-v53v-4qmm Record: https://patchnext.com/advisories/cve-2026-13426 (revision 2, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/public 0.1.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/public: affected < 0.1.22; fixed in 0.1.22 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/public: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/public. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72v2-v53v-4qmm (GitHub-reviewed advisory GHSA-72v2-v53v-4qmm lists affected ranges: Go github.com/mattermost/mattermost/server/public >=0 <0.1.22) - Verified: https://osv.dev/vulnerability/GHSA-72v2-v53v-4qmm (OSV record GHSA-72v2-v53v-4qmm lists affected ranges: Go github.com/mattermost/mattermost/server/public >=0 <0.1.22 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…