Skip to content

← Actionable
Medium, CVSS 5.6

pip would incorrectly handle doubly-encoded package URLs from indexes

CVE-2026-13346GHSA-qwm4-qh6w-59xr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pip 26.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pip

    Affected
    < 26.2.0
    Fixed in
    26.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.6 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-13346: 0.29% estimated exploitation activity in the next 30 days; percentile 21.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

pip would incorrectly handle doubly-encoded package URLs from indexes allowing for files to be installed to arbitrary locations on disk even when installing wheels. This vulnerability requires downloading or installing a package from a malicious package index to succeed, malicious packages alone are not able to exploit this vulnerability. Note that this vulnerability only materially impacts users running pip download with the --only-binary option as installing source distributions from an untrusted index is already an unsafe operation that executes code during install time.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qwm4-qh6w-59xr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-13346

Advisory: pip would incorrectly handle doubly-encoded package URLs from indexes
IDs: CVE-2026-13346, GHSA-qwm4-qh6w-59xr
Record: https://patchnext.com/advisories/cve-2026-13346 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pip 26.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pip: affected < 26.2.0; fixed in 26.2.0

## Suggested inspection (read-only)
- `python -m pip show pip`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pip.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qwm4-qh6w-59xr (GitHub-reviewed advisory GHSA-qwm4-qh6w-59xr lists affected ranges: PyPI pip >=0 <26.2.0)

Commands are suggestions: review each one before running it.

Loading voting…