Skip to content

← Actionable
High, CVSS 7.7amended

brace-expansion: DoS via exponential-time expansion of consecutive non-expanding {} groups

CVE-2026-13149GHSA-3jxr-9vmj-r5cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (brace-expansion 5.0.7, 2.1.2, 1.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm brace-expansion

    Affected
    >= 3.0.0, < 5.0.7< 1.1.16>= 2.0.0, < 2.1.2
    Fixed in
    2.1.2, 1.1.16, 5.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/S:N/AU:Y/R:U/V:D/RE:M/U:Amber · score source
EPSS
  • CVE-2026-13149: 0.36% estimated exploitation activity in the next 30 days; percentile 30.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary brace-expansion's expand() exhibits exponential-time - O(2ⁿ) - behavior in the number of consecutive non-expanding {} groups. A short, all-ASCII input (~90 bytes/30 groups) blocks the calling thread for minutes; a slightly longer input hangs it effectively indefinitely. Because the dominant consumers run on Node's single-threaded event loop, one small input can fully stall a worker/process. In expand, post is computed unconditionally at the top of the function, before the early-return branches that don't use it: For input like a{},{},…, the first {} is non-expanding, so control reaches the {a},b} rewrite branch - but expand has already recursed into post over the entire remaining tail, only to throw the result away. Each level therefore spawns two recursive expansions over essentially the same remaining work: T(n) = 2·T(n−1) ⇒ O(2ⁿ). The max option does not mitigate this: max only bounds the output-building loops; neither the post recursion nor the rewrite recursion consults…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3jxr-9vmj-r5cp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3jxr-9vmj-r5cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-13149

Advisory: brace-expansion: DoS via exponential-time expansion of consecutive non-expanding {} groups
IDs: CVE-2026-13149, GHSA-3jxr-9vmj-r5cp
Record: https://patchnext.com/advisories/cve-2026-13149 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: brace-expansion 5.0.7, 2.1.2, 1.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm brace-expansion: affected >= 3.0.0, < 5.0.7; < 1.1.16; >= 2.0.0, < 2.1.2; fixed in 2.1.2, 1.1.16, 5.0.7

## Suggested inspection (read-only)
- `npm ls brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on brace-expansion.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3jxr-9vmj-r5cp (OSV record GHSA-3jxr-9vmj-r5cp lists affected ranges: npm brace-expansion >=3.0.0 =0 =2.0.0 <2.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3jxr-9vmj-r5cp (GitHub-reviewed advisory GHSA-3jxr-9vmj-r5cp lists affected ranges: npm brace-expansion >=3.0.0 =0 =2.0.0 <2.1.2)

Commands are suggestions: review each one before running it.

Loading voting…