Language Servers for AWS Vulnerable to Arbitrary Code Execution
CVE-2026-12957GHSA-xhcr-j4j9-3gh7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@aws/lsp-codewhisperer 0.0.113), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.113
- Fixed in
- 0.0.113
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xhcr-j4j9-3gh7 lists affected ranges: npm @aws/lsp-codewhisperer >=0 <0.0.113
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xhcr-j4j9-3gh7 lists affected ranges: npm @aws/lsp-codewhisperer >=0 <0.0.113 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-12957: 0.23% estimated exploitation activity in the next 30 days; percentile 14.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Language Servers for AWS (the aws/language-servers project) provide the underlying language-server runtime that powers Amazon Q Developer's AI coding assistance across its IDE plugins (Visual Studio Code, JetBrains, Eclipse, and Visual Studio). Improper trust boundary enforcement in Language Servers for AWS may allow for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. Impact When a local user opens a maliciously crafted workspace and trusts it when prompted, commands defined in the workspace's project-level configuration files may be executed automatically, resulting in arbitrary code execution on the user's host. This issue is triggered when a user opens a workspace, trusts it, and the agent subsequently executes commands defined in the project-level configuration files. Impacted versions: Language Servers for AWS version <1.65.0. Patches This issue has been…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-xhcr-j4j9-3gh7
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-xhcr-j4j9-3gh7
- Revision 1 · created ·
Published from ghsa record GHSA-xhcr-j4j9-3gh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-12957 Advisory: Language Servers for AWS Vulnerable to Arbitrary Code Execution IDs: CVE-2026-12957, GHSA-xhcr-j4j9-3gh7 Record: https://patchnext.com/advisories/cve-2026-12957 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @aws/lsp-codewhisperer 0.0.113. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @aws/lsp-codewhisperer: affected < 0.0.113; fixed in 0.0.113 ## Suggested inspection (read-only) - `npm ls @aws/lsp-codewhisperer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @aws/lsp-codewhisperer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xhcr-j4j9-3gh7 (GitHub-reviewed advisory GHSA-xhcr-j4j9-3gh7 lists affected ranges: npm @aws/lsp-codewhisperer >=0 <0.0.113) - Verified: https://osv.dev/vulnerability/GHSA-xhcr-j4j9-3gh7 (OSV record GHSA-xhcr-j4j9-3gh7 lists affected ranges: npm @aws/lsp-codewhisperer >=0 <0.0.113 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…