body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement
CVE-2026-12590GHSA-v422-hmwv-36x6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (body-parser 2.3.0, 1.20.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm body-parser
- Affected
- < 1.20.6>= 2.0.0, < 2.3.0
- Fixed in
- 2.3.0, 1.20.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v422-hmwv-36x6 lists affected ranges: npm body-parser >=0 =2.0.0 <2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v422-hmwv-36x6 lists affected ranges: npm body-parser >=0 =2.0.0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-12590: 0.41% estimated exploitation activity in the next 30 days; percentile 35.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When body-parser is configured with an invalid limit option value, such as an unparseable string or NaN, bytes.parse() returns null and the request body size check is silently skipped. Applications that rely on limit as their primary safeguard against oversized request bodies will accept arbitrarily large payloads, leading to excessive memory and CPU usage and denial of service. This issue affects applications that pass a programmatically computed or user-configurable value to the limit option without validating it first. Patches This issue is fixed in body-parser@2.3.0 and body-parser@1.20.6 via #698. After the fix, invalid limit values throw a clear error at parser construction time instead of silently disabling enforcement. null and undefined continue to fall back to the default limit (100kb). Workarounds Validate limit before passing it to body-parser. For example, parse the value with bytes.parse() at startup and reject any configuration where it returns null or a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v422-hmwv-36x6
- Revision 1 · created ·
Published from osv record GHSA-v422-hmwv-36x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-12590 Advisory: body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement IDs: CVE-2026-12590, GHSA-v422-hmwv-36x6 Record: https://patchnext.com/advisories/cve-2026-12590 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: body-parser 2.3.0, 1.20.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm body-parser: affected < 1.20.6; >= 2.0.0, < 2.3.0; fixed in 2.3.0, 1.20.6 ## Suggested inspection (read-only) - `npm ls body-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on body-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v422-hmwv-36x6 (OSV record GHSA-v422-hmwv-36x6 lists affected ranges: npm body-parser >=0 =2.0.0 <2.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v422-hmwv-36x6 (GitHub-reviewed advisory GHSA-v422-hmwv-36x6 lists affected ranges: npm body-parser >=0 =2.0.0 <2.3.0) Commands are suggestions: review each one before running it.
Loading voting…