Skip to content

← Actionable
Medium, CVSS 6.5amended

BBOT: Arbitrary File Write in postman_download Module

CVE-2026-12568GHSA-m54h-vhf9-3w3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bbot 2.8.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bbot

    Affected
    >= 2.1.0, <= 2.8.5
    Fixed in
    2.8.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-12568: 0.25% estimated exploitation activity in the next 30 days; percentile 16.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The postmandownload module uses the workspace name field from the Postman API to construct the local directory path without sanitization. If a malicious workspace has a name containing path traversal characters, pathlib resolves the path outside the intended output directory, allowing an attacker to write arbitrary files to the user's system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m54h-vhf9-3w3m

  2. Revision 1 · created ·

    Published from osv record GHSA-m54h-vhf9-3w3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12568

Advisory: BBOT: Arbitrary File Write in postman_download Module
IDs: CVE-2026-12568, GHSA-m54h-vhf9-3w3m
Record: https://patchnext.com/advisories/cve-2026-12568 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bbot 2.8.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bbot: affected >= 2.1.0, <= 2.8.5; fixed in 2.8.6

## Suggested inspection (read-only)
- `python -m pip show bbot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m54h-vhf9-3w3m (OSV record GHSA-m54h-vhf9-3w3m lists affected ranges: PyPI bbot >=2.1.0 <2.8.6 (fixed))
- Verified: https://github.com/advisories/GHSA-m54h-vhf9-3w3m (GitHub-reviewed advisory GHSA-m54h-vhf9-3w3m lists affected ranges: PyPI bbot >=2.1.0 <=2.8.5)

Commands are suggestions: review each one before running it.

Loading voting…