BBOT: Symlink-Following Arbitrary Write via github_workflows Module
CVE-2026-12567GHSA-rvp7-w75q-9fv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bbot 2.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI bbot
- Affected
- >= 2.0.0, <= 2.8.4
- Fixed in
- 2.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rvp7-w75q-9fv2 lists affected ranges: PyPI bbot >=2.0.0 <2.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rvp7-w75q-9fv2 lists affected ranges: PyPI bbot >=2.0.0 <=2.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.2 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-12567: 0.09% estimated exploitation activity in the next 30 days; percentile 0.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The githubworkflows module constructs local directory paths from user-controlled repository names without validating for symlinks. A local attacker sharing the scan directory can plant a symlink at the predictable output path, causing workflow data to be written to an attacker-chosen location.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rvp7-w75q-9fv2
- Revision 1 · created ·
Published from osv record GHSA-rvp7-w75q-9fv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-12567 Advisory: BBOT: Symlink-Following Arbitrary Write via github_workflows Module IDs: CVE-2026-12567, GHSA-rvp7-w75q-9fv2 Record: https://patchnext.com/advisories/cve-2026-12567 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bbot 2.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI bbot: affected >= 2.0.0, <= 2.8.4; fixed in 2.8.5 ## Suggested inspection (read-only) - `python -m pip show bbot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rvp7-w75q-9fv2 (OSV record GHSA-rvp7-w75q-9fv2 lists affected ranges: PyPI bbot >=2.0.0 <2.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-rvp7-w75q-9fv2 (GitHub-reviewed advisory GHSA-rvp7-w75q-9fv2 lists affected ranges: PyPI bbot >=2.0.0 <=2.8.4) Commands are suggestions: review each one before running it.
Loading voting…