BBOT: Server-Side Request Forgery (SSRF) in docker_pull module via WWW-Authenticate realm parsing
CVE-2026-12566GHSA-3mp7-vp6j-2mxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bbot 2.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI bbot
- Affected
- >= 2.0.0, <= 2.8.4
- Fixed in
- 2.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3mp7-vp6j-2mxx lists affected ranges: PyPI bbot >=2.0.0 <2.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3mp7-vp6j-2mxx lists affected ranges: PyPI bbot >=2.0.0 <=2.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-12566: 0.17% estimated exploitation activity in the next 30 days; percentile 5.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The dockerpull module uses the realm parameter from a Docker registry's WWW-Authenticate response header as the authentication endpoint without validation. An attacker in a man-in-the-middle position between bbot and a Docker registry could modify this header to redirect the authentication request to an arbitrary endpoint, potentially leaking authentication tokens.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3mp7-vp6j-2mxx
- Revision 1 · created ·
Published from osv record GHSA-3mp7-vp6j-2mxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-12566 Advisory: BBOT: Server-Side Request Forgery (SSRF) in docker_pull module via WWW-Authenticate realm parsing IDs: CVE-2026-12566, GHSA-3mp7-vp6j-2mxx Record: https://patchnext.com/advisories/cve-2026-12566 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bbot 2.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI bbot: affected >= 2.0.0, <= 2.8.4; fixed in 2.8.5 ## Suggested inspection (read-only) - `python -m pip show bbot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3mp7-vp6j-2mxx (OSV record GHSA-3mp7-vp6j-2mxx lists affected ranges: PyPI bbot >=2.0.0 <2.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-3mp7-vp6j-2mxx (GitHub-reviewed advisory GHSA-3mp7-vp6j-2mxx lists affected ranges: PyPI bbot >=2.0.0 <=2.8.4) Commands are suggestions: review each one before running it.
Loading voting…