Skip to content

← Actionable
High, CVSS 8.4amended

Improper neutralization of argument delimiters in AWS Bedrock AgentCore Python SDK install_packages()

CVE-2026-12530GHSA-6rfw-mq36-jm8h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bedrock-agentcore 1.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-12530: 0.34% estimated exploitation activity in the next 30 days; percentile 27.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AWS Bedrock AgentCore Python SDK (bedrock-agentcore) is an open-source SDK that enables developers to build, deploy, and manage agents on AWS Bedrock AgentCore. An issue exists in the installpackages() method of the Code Interpreter client where crafted package name arguments can bypass input validation and allow a remote authenticated user to execute arbitrary commands within the Code Interpreter sandbox. Impact The installpackages() method constructs a 'pip install' shell command executed within the Code Interpreter sandbox using package name arguments provided by the caller. The method applied an incomplete blocklist that allowed crafted package name arguments - specifically pip flags such as '--index-url' and '-r' - to pass validation unchecked. A remote authenticated user who can influence the arguments passed to installpackages() could redirect package resolution to a third-party-controlled PyPI server, or expose the contents of arbitrary sandbox files and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6rfw-mq36-jm8h

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6rfw-mq36-jm8h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12530

Advisory: Improper neutralization of argument delimiters in AWS Bedrock AgentCore Python SDK install_packages()
IDs: CVE-2026-12530, GHSA-6rfw-mq36-jm8h
Record: https://patchnext.com/advisories/cve-2026-12530 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bedrock-agentcore 1.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bedrock-agentcore: affected >= 1.1.3, < 1.6.1; fixed in 1.6.1

## Suggested inspection (read-only)
- `python -m pip show bedrock-agentcore`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bedrock-agentcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6rfw-mq36-jm8h (OSV record GHSA-6rfw-mq36-jm8h lists affected ranges: PyPI bedrock-agentcore >=1.1.3 <1.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6rfw-mq36-jm8h (GitHub-reviewed advisory GHSA-6rfw-mq36-jm8h lists affected ranges: PyPI bedrock-agentcore >=1.1.3 <1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…