Skip to content

← Actionable
High, CVSS 7.8amended

Keras: TorchModuleWrapper can deserialize unsafe PyTorch pickle data

CVE-2026-12484GHSA-v2w2-w228-c444

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keras 3.15.0, 3.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI keras

    Affected
    < 3.12.3>= 3.13.0, < 3.15.0
    Fixed in
    3.15.0, 3.12.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-12484: 0.30% estimated exploitation activity in the next 30 days; percentile 23.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in keras-team/keras version 3.15.0 allows unsafe deserialization of attacker-controlled PyTorch pickle data through the public keras.layers.TorchModuleWrapper.fromconfig method. This method invokes torch.load(..., weightsonly=False) without requiring an explicit unsafe opt-in, such as a safemode=False parameter. When called outside a SafeModeScope(True) context, the absence of an ambient safe mode state permits unsafe deserialization by default. This issue can lead to arbitrary code execution if untrusted Keras layer configurations are processed using this method. The vulnerability arises because the method does not enforce safe deserialization practices unless explicitly guarded by Keras safe mode.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v2w2-w228-c444

  2. Revision 1 · created ·

    Published from osv record GHSA-v2w2-w228-c444

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12484

Advisory: Keras: TorchModuleWrapper can deserialize unsafe PyTorch pickle data
IDs: CVE-2026-12484, GHSA-v2w2-w228-c444
Record: https://patchnext.com/advisories/cve-2026-12484 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keras 3.15.0, 3.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI keras: affected < 3.12.3; >= 3.13.0, < 3.15.0; fixed in 3.15.0, 3.12.3

## Suggested inspection (read-only)
- `python -m pip show keras`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keras.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v2w2-w228-c444 (OSV record GHSA-v2w2-w228-c444 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v2w2-w228-c444 (GitHub-reviewed advisory GHSA-v2w2-w228-c444 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0)

Commands are suggestions: review each one before running it.

Loading voting…