Keras: Lambda deserialization can bypass safe mode and execute code
CVE-2026-12481GHSA-5gwj-m78q-7pq3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keras 3.15.0, 3.12.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keras
- Affected
- < 3.12.3>= 3.13.0, < 3.15.0
- Fixed in
- 3.15.0, 3.12.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5gwj-m78q-7pq3 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5gwj-m78q-7pq3 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-12481: 0.72% estimated exploitation activity in the next 30 days; percentile 53.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in keras-team/keras version 3.14.0 allows for arbitrary code execution due to improper handling of deserialization in the Lambda layer. Specifically, the raiseforlambdadeserialization() function fails to enforce the safe-mode guard when safemode is set to None, which is the default value when fromconfig() is called outside of a SafeModeScope context. This logic error conflates None (unset/default-deny) with False (explicitly disabled), bypassing the guard and allowing attacker-controlled marshal bytecode to be deserialized. Affected call sites include keras.layers.deserialize(config), keras.models.clonemodel(model), and any direct invocation of Lambda.fromconfig(config) without an enclosing SafeModeScope(True). This vulnerability can be exploited to achieve arbitrary OS-level code execution in the context of the server or user process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5gwj-m78q-7pq3
- Revision 1 · created ·
Published from osv record GHSA-5gwj-m78q-7pq3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-12481 Advisory: Keras: Lambda deserialization can bypass safe mode and execute code IDs: CVE-2026-12481, GHSA-5gwj-m78q-7pq3 Record: https://patchnext.com/advisories/cve-2026-12481 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keras 3.15.0, 3.12.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keras: affected < 3.12.3; >= 3.13.0, < 3.15.0; fixed in 3.15.0, 3.12.3 ## Suggested inspection (read-only) - `python -m pip show keras`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keras. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5gwj-m78q-7pq3 (OSV record GHSA-5gwj-m78q-7pq3 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5gwj-m78q-7pq3 (GitHub-reviewed advisory GHSA-5gwj-m78q-7pq3 lists affected ranges: PyPI keras >=0 =3.13.0 <3.15.0) Commands are suggestions: review each one before running it.
Loading voting…