Skip to content

← Actionable
Medium, CVSS 5.3amended

NLTK: Missing Post-Download Integrity Verification Allows Malicious Package Injection

CVE-2026-12259GHSA-5wp5-5229-5g6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    < 3.9.3
    Fixed in
    3.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-12259: 0.10% estimated exploitation activity in the next 30 days; percentile 0.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

NLTK's package downloader in nltk/downloader.py does not verify file integrity after download and before extraction. The download flow at lines 789-825: 1. File is downloaded to a temp path via HTTP 2. os.replace(tmp_filepath, filepath) moves it to the final location (line 799) 3. Extraction begins via _unzip_iter() (line 825) Between steps 2 and 3, there is no SHA-256 verification. The checksum logic exists in _pkg_status() (lines 982-1015) but it is only used BEFORE download as a status check ("is this package already installed and up-to-date?"). It is never called after download to verify the file that was actually received. Attack vectors: 1. MITM during HTTP download (NLTK downloads from http:// by default on some mirrors) 2. Race condition on shared filesystems (attacker replaces file between os.replace and _unzip_iter) 3. DNS poisoning redirecting to attacker-controlled server PoC: ```python import nltk import unittest.mock import zipfile import io import os

Create a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-5wp5-5229-5g6q

  2. Revision 1 · created ·

    Published from ghsa record GHSA-5wp5-5229-5g6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12259

Advisory: NLTK: Missing Post-Download Integrity Verification Allows Malicious Package Injection
IDs: CVE-2026-12259, GHSA-5wp5-5229-5g6q
Record: https://patchnext.com/advisories/cve-2026-12259 (revision 2, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected < 3.9.3; fixed in 3.9.3

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5wp5-5229-5g6q (GitHub-reviewed advisory GHSA-5wp5-5229-5g6q lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://osv.dev/vulnerability/GHSA-5wp5-5229-5g6q (OSV record GHSA-5wp5-5229-5g6q lists affected ranges: PyPI nltk >=0 <3.9.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…