Skip to content

← Actionable
High, CVSS 7.8amended

NLTK Stanford wrapper classes execute untrusted JAR files without verification

CVE-2026-12252GHSA-9r6g-266r-89x4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    < 3.9.4
    Fixed in
    3.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-12252: 0.19% estimated exploitation activity in the next 30 days; percentile 9.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the java() function, which invokes subprocess.Popen() without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9r6g-266r-89x4

  2. Revision 1 · created ·

    Published from osv record GHSA-9r6g-266r-89x4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12252

Advisory: NLTK Stanford wrapper classes execute untrusted JAR files without verification
IDs: CVE-2026-12252, GHSA-9r6g-266r-89x4
Record: https://patchnext.com/advisories/cve-2026-12252 (revision 2, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected < 3.9.4; fixed in 3.9.4

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9r6g-266r-89x4 (OSV record GHSA-9r6g-266r-89x4 lists affected ranges: PyPI nltk >=0 <3.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-9r6g-266r-89x4 (GitHub-reviewed advisory GHSA-9r6g-266r-89x4 lists affected ranges: PyPI nltk >=0 <3.9.4)

Commands are suggestions: review each one before running it.

Loading voting…