Skip to content

← Actionable
Critical, CVSS 9.0amended

Canonical ADSys Uses a Less Trusted Source

CVE-2026-12249GHSA-crm4-q7v4-c2r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ubuntu/adsys 0.16.3-0.20250318112551-8b1939f96d38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/ubuntu/adsys

    Affected
    < 0.16.3-0.20250318112551-8b1939f96d38
    Fixed in
    0.16.3-0.20250318112551-8b1939f96d38

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/S:N/AU:Y/R:I/V:D/RE:L/U:Red · score source
EPSS
  • CVE-2026-12249: 0.14% estimated exploitation activity in the next 30 days; percentile 3.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Canonical ADSys upstream versions through v0.16.2. During Active Directory Certificate Services (AD CS) certificate auto-enrollment via the vendored Samba client script (internal/policies/certificate/python/vendorsamba/gp/gpcertautoenrollext.py), ADSys utilizes a plaintext HTTP connection (http://) instead of a secure HTTPS connection (https://) to request the CA certificate from the Active Directory Certificate Services server (GetCACert). An unauthenticated network attacker positioned between the managed Ubuntu host and the configured AD CS CA hostname can conduct a Man-in-the-Middle (MITM) attack. By intercepting the plaintext HTTP request, the attacker can supply an arbitrary, attacker-controlled Root CA certificate. Because the system automatically accepts this certificate and registers it into the local system trust store via update-ca-certificates, this results in system-wide trust store poisoning. Consequently, TLS clients utilizing the operating…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-crm4-q7v4-c2r2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GO-2026-6543

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12249

Advisory: Canonical ADSys Uses a Less Trusted Source
IDs: CVE-2026-12249, GHSA-crm4-q7v4-c2r2
Record: https://patchnext.com/advisories/cve-2026-12249 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ubuntu/adsys 0.16.3-0.20250318112551-8b1939f96d38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ubuntu/adsys: affected < 0.16.3-0.20250318112551-8b1939f96d38; fixed in 0.16.3-0.20250318112551-8b1939f96d38

## Suggested inspection (read-only)
- Go github.com/ubuntu/adsys: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ubuntu/adsys.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6543 (OSV record GO-2026-6543 lists affected ranges: Go github.com/ubuntu/adsys >=0)
- Verified: https://github.com/advisories/GHSA-crm4-q7v4-c2r2 (GitHub-reviewed advisory GHSA-crm4-q7v4-c2r2 lists affected ranges: Go github.com/ubuntu/adsys >=0 <0.16.3-0.20250318112551-8b1939f96d38)

Commands are suggestions: review each one before running it.

Loading voting…