Skip to content

← Actionable
Medium, CVSS 4.7

utcp-gql SSRF: CVE-2026-44661 fix not applied to the GraphQL and WebSocket plugins

CVE-2026-12210GHSA-ppx3-28rw-8fpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (utcp-gql 1.1.1; utcp-websocket 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-12210: 0.23% estimated exploitation activity in the next 30 days; percentile 13.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for CVE-2026-44661 (commit 5b16e43) added the ensuresecureurl() / issecureurl() helpers and wired them into the three HTTP-family plugins, but it did not reach the GraphQL or WebSocket plugins. The GraphQL plugin (utcp-gql) still uses the startswith prefix check that the fix explicitly replaced, so http://127.0.0.1.attacker.example and http://localhost.evil.com pass it. The WebSocket plugin (utcp-websocket) performs no URL validation at all, even though its own docstrings state it enforces "WSS or localhost only." Both plugins reach the same SSRF that CVE-2026-44661 was filed for, and because both attach the call template's configured auth headers to the outbound connection, the SSRF can also leak API keys and OAuth tokens to an attacker-controlled host. Details In the CVE-2026-44661 fix (commit 5b16e43 ("fix(http): block SSRF via attacker-controlled OpenAPI servers[0].url")), two things in it pointed at sibling issues. The commit message says the change is "replacing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ppx3-28rw-8fpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12210

Advisory: utcp-gql SSRF: CVE-2026-44661 fix not applied to the GraphQL and WebSocket plugins
IDs: CVE-2026-12210, GHSA-ppx3-28rw-8fpf
Record: https://patchnext.com/advisories/cve-2026-12210 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: utcp-gql 1.1.1; utcp-websocket 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI utcp-gql: affected <= 1.1.0; fixed in 1.1.1
- PyPI utcp-websocket: affected <= 1.1.0; fixed in 1.1.1

## Suggested inspection (read-only)
- `python -m pip show utcp-gql`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show utcp-websocket`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on utcp-gql, utcp-websocket.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ppx3-28rw-8fpf (GitHub-reviewed advisory GHSA-ppx3-28rw-8fpf lists affected ranges: PyPI utcp-gql >=0 =0 <=1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…