Skip to content

← Actionable
High, CVSS 8.7amended

form-data: CRLF injection in form-data via unescaped multipart field names and filenames

CVE-2026-12143GHSA-hmw2-7cc7-3qxx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (form-data 4.0.6, 3.0.5, 2.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm form-data

    Affected
    < 2.5.6>= 3.0.0, < 3.0.5>= 4.0.0, < 4.0.6
    Fixed in
    4.0.6, 3.0.5, 2.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-12143: 0.67% estimated exploitation activity in the next 30 days; percentile 52.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary form-data builds multipart/form-data request bodies. Through v4.0.5, the field name passed to FormData#append and the filename option are concatenated directly into the Content-Disposition header with no escaping of CR (\r), LF (\n), or ". An application that uses untrusted input as a field name or filename therefore lets an attacker terminate the header line and either inject additional headers or smuggle whole additional multipart parts into the request the application forwards to a backend. This is CWE-93 (CRLF injection). It is a divergence from how browsers and the WHATWG HTML spec serialize form-data (they escape these characters), so the fix is to match that behavior. Severity is conditional: it depends on the consuming application passing attacker-controlled data as a field name or filename. Applications that only use fixed/trusted field names are not affected. Details In lib/formdata.js, multiPartHeader builds the part header as: and getContentDisposition builds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hmw2-7cc7-3qxx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hmw2-7cc7-3qxx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-12143

Advisory: form-data: CRLF injection in form-data via unescaped multipart field names and filenames
IDs: CVE-2026-12143, GHSA-hmw2-7cc7-3qxx
Record: https://patchnext.com/advisories/cve-2026-12143 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: form-data 4.0.6, 3.0.5, 2.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm form-data: affected < 2.5.6; >= 3.0.0, < 3.0.5; >= 4.0.0, < 4.0.6; fixed in 4.0.6, 3.0.5, 2.5.6

## Suggested inspection (read-only)
- `npm ls form-data --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on form-data.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hmw2-7cc7-3qxx (OSV record GHSA-hmw2-7cc7-3qxx lists affected ranges: npm form-data >=0 =3.0.0 =4.0.0 <4.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-hmw2-7cc7-3qxx (GitHub-reviewed advisory GHSA-hmw2-7cc7-3qxx lists affected ranges: npm form-data >=0 =3.0.0 =4.0.0 <4.0.6)

Commands are suggestions: review each one before running it.

Loading voting…