Skip to content

← Actionable
High, CVSS 7.5amended

GraphQL-core has denial of service via memory leak in aborted validations

CVE-2026-119286GHSA-mpqx-q82w-9x46

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-core 3.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-119286: 0.42% estimated exploitation activity in the next 30 days; percentile 36.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When a validation was aborted because the document contained more errors than allowed by `max_errors` (100 by default), `validate()` raised a single module-level `ValidationAbortedError` instance. Python appends the frames of every `raise` to the existing `traceback` of an exception that is raised again, so every aborted validation extended the traceback of this shared error. That traceback kept the frames, and with them the document, the validation context and all errors of every aborted validation, alive for the lifetime of the process.

Details Any client can trigger an aborted validation by sending a small document with more than 100 validation errors, e.g. 101 unknown fields. No authentication is required, and since validation runs before execution, depth limiters and complexity analyzers do not prevent it. Each such request permanently retained about 124 KiB on CPython 3.12, without an upper limit, so memory grew with every request until the process was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-mpqx-q82w-9x46

  2. Revision 1 · created ·

    Published from ghsa record GHSA-mpqx-q82w-9x46

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119286

Advisory: GraphQL-core has denial of service via memory leak in aborted validations
IDs: CVE-2026-119286, GHSA-mpqx-q82w-9x46
Record: https://patchnext.com/advisories/cve-2026-119286 (revision 2, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphql-core 3.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI graphql-core: affected >= 3.3.0a3, < 3.3.1; fixed in 3.3.1

## Suggested inspection (read-only)
- `python -m pip show graphql-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphql-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mpqx-q82w-9x46 (GitHub-reviewed advisory GHSA-mpqx-q82w-9x46 lists affected ranges: PyPI graphql-core >=3.3.0a3 <3.3.1)
- Verified: https://osv.dev/vulnerability/GHSA-mpqx-q82w-9x46 (OSV record GHSA-mpqx-q82w-9x46 lists affected ranges: PyPI graphql-core >=3.3.0a3 <3.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…