MariaDB Connector/J: Length-encoded integers larger than Integer.MAX_VALUE were truncated before being used as lengths
CVE-2026-119279GHSA-797x-p4mc-jwpm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.mariadb.jdbc:mariadb-java-client 3.5.10, 3.4.5, 3.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.mariadb.jdbc:mariadb-java-client
- Affected
- >= 3.0.0, < 3.3.7>= 3.4.0, < 3.4.5>= 3.5.0, < 3.5.10
- Fixed in
- 3.3.7, 3.5.10, 3.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-797x-p4mc-jwpm lists affected ranges: Maven org.mariadb.jdbc:mariadb-java-client >=3.0.0 =3.4.0 =3.5.0 <3.5.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-797x-p4mc-jwpm lists affected ranges: Maven org.mariadb.jdbc:mariadb-java-client >=3.0.0 =3.4.0 =3.5.0 <3.5.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-119279: 0.35% estimated exploitation activity in the next 30 days; percentile 28.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary MariaDB Connector/J narrowed 8-byte length-encoded integers received from the server to `int` without validation. A rogue or MitM server can send a value above `Integer.MAX_VALUE` whose truncation becomes a negative or arbitrary length.
Details The protocol encodes lengths as length-encoded integers, whose 8-byte form the decoder (`readLength()` and `readIntLengthEncodedNotNull()`) returned as `(int) readLong()`. A value above `Integer.MAX_VALUE` therefore wrapped to a negative or unrelated `int`, used afterwards as a length to size allocations or reads, which ended in `NegativeArraySizeException`, out-of-bounds exceptions or oversized allocations. The fix rejects any length-encoded value that does not fit a non-negative `int` with an explicit error.
Impact Availability only: a malicious or compromised server, or a MitM, can crash the client's connection handling with unchecked exceptions or drive oversized allocations. Exploitation requires control of the server…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-797x-p4mc-jwpm
- Revision 1 · created ·
Published from ghsa record GHSA-797x-p4mc-jwpm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-119279 Advisory: MariaDB Connector/J: Length-encoded integers larger than Integer.MAX_VALUE were truncated before being used as lengths IDs: CVE-2026-119279, GHSA-797x-p4mc-jwpm Record: https://patchnext.com/advisories/cve-2026-119279 (revision 2, source checked 31 Oct 2026, 07:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.mariadb.jdbc:mariadb-java-client 3.5.10, 3.4.5, 3.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.mariadb.jdbc:mariadb-java-client: affected >= 3.0.0, < 3.3.7; >= 3.4.0, < 3.4.5; >= 3.5.0, < 3.5.10; fixed in 3.3.7, 3.5.10, 3.4.5 ## Suggested inspection (read-only) - Maven org.mariadb.jdbc:mariadb-java-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.mariadb.jdbc:mariadb-java-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-797x-p4mc-jwpm (GitHub-reviewed advisory GHSA-797x-p4mc-jwpm lists affected ranges: Maven org.mariadb.jdbc:mariadb-java-client >=3.0.0 =3.4.0 =3.5.0 <3.5.10) - Verified: https://osv.dev/vulnerability/GHSA-797x-p4mc-jwpm (OSV record GHSA-797x-p4mc-jwpm lists affected ranges: Maven org.mariadb.jdbc:mariadb-java-client >=3.0.0 =3.4.0 =3.5.0 <3.5.10 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…