Skip to content

← Actionable
High, CVSS 7.5amended

pyasn1 has quadratic-complexity denial of service in binary REAL decoding

CVE-2026-119197GHSA-mm57-4v3p-rchx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyasn1

    Affected
    < 0.6.5
    Fixed in
    0.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-119197: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In pyasn1 0.6.4 and earlier, decoding a binary-encoded ASN.1 REAL with a large mantissa can consume CPU time quadratic in the mantissa length. The BER, CER, and DER decoders all use the affected `RealPayloadDecoder`. An application is exposed when it passes attacker-controlled ASN.1 containing a REAL value to one of these decoders, either without an `asn1Spec` or with a schema that includes REAL. The work occurs inside `decode()`; the application does not need to convert, print, or otherwise use the resulting REAL object. This is distinct from CVE-2026-59886, which concerns converting an already-decoded REAL to a Python float. That issue was fixed in 0.6.4 and its advisory states that decoding alone does not trigger it.

Root cause and affected components For binary REAL values, `RealPayloadDecoder.valueDecoder` in v0.6.4 builds the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-mm57-4v3p-rchx

  2. Revision 1 · created ·

    Published from ghsa record GHSA-mm57-4v3p-rchx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119197

Advisory: pyasn1 has quadratic-complexity denial of service in binary REAL decoding
IDs: CVE-2026-119197, GHSA-mm57-4v3p-rchx
Record: https://patchnext.com/advisories/cve-2026-119197 (revision 2, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyasn1: affected < 0.6.5; fixed in 0.6.5

## Suggested inspection (read-only)
- `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyasn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mm57-4v3p-rchx (GitHub-reviewed advisory GHSA-mm57-4v3p-rchx lists affected ranges: PyPI pyasn1 >=0 <=0.6.4)
- Verified: https://osv.dev/vulnerability/GHSA-mm57-4v3p-rchx (OSV record GHSA-mm57-4v3p-rchx lists affected ranges: PyPI pyasn1 >=0 <0.6.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…