Skip to content

← Actionable
High, CVSS 7.5amended

pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding

CVE-2026-119196GHSA-2qm8-x737-gmw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyasn1

    Affected
    < 0.6.5
    Fixed in
    0.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-119196: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In pyasn1 through 0.6.4, decoding a constructed BIT STRING with many fragments repeatedly shifts and copies the entire value accumulated so far. For fixed-size fragments, CPU time grows quadratically with the encoded input size. An application that passes sufficiently large, attacker-controlled ASN.1 data to an affected decoder can suffer CPU exhaustion during `decode()`; no conversion or formatting of the decoded value is required. The BER and CER decoders reach this path for constructed BIT STRING values, with or without an `asn1Spec`. The DER decoder rejects constructed BIT STRING in schema-less decoding, but its schema-driven path accepts a definite-length constructed BIT STRING when given a matching `asn1Spec` and reaches the same vulnerable code. Constructed BIT STRING is not valid DER; this DER exposure is due to decoder permissiveness. DER rejects the indefinite-length form. This is a separate decoder path from the OBJECT IDENTIFIER accumulation fixed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-2qm8-x737-gmw5

  2. Revision 1 · created ·

    Published from ghsa record GHSA-2qm8-x737-gmw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119196

Advisory: pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding
IDs: CVE-2026-119196, GHSA-2qm8-x737-gmw5
Record: https://patchnext.com/advisories/cve-2026-119196 (revision 2, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyasn1: affected < 0.6.5; fixed in 0.6.5

## Suggested inspection (read-only)
- `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyasn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qm8-x737-gmw5 (GitHub-reviewed advisory GHSA-2qm8-x737-gmw5 lists affected ranges: PyPI pyasn1 >=0 <=0.6.4)
- Verified: https://osv.dev/vulnerability/GHSA-2qm8-x737-gmw5 (OSV record GHSA-2qm8-x737-gmw5 lists affected ranges: PyPI pyasn1 >=0 <0.6.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…