Skip to content

← Actionable
High, CVSS 7.5amended

Forge: Denial of service in TLS record processing via a record interleaved with a fragmented handshake message

CVE-2026-119188GHSA-8hrf-8g6f-7xwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-forge 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-119188: 0.41% estimated exploitation activity in the next 30 days; percentile 35.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A connection created with `forge.tls.createConnection()` throws an uncaught `TypeError` from `process()` when it receives a record of another content type while waiting for the rest of a handshake message that was split across records. A peer can trigger this with 18 bytes before the handshake, without authentication, which terminates Node.js processes that use the documented socket wiring. Fixed in node-forge 1.4.1.

Details In `lib/tls.js`, `_readRecord()` handles a record that arrives while a handshake message split across records is incomplete. If the record has any other content type (change_cipher_spec, alert, application_data or heartbeat), forge correctly reports "Invalid fragmented record." through `c.error()` with a fatal `unexpected_message` alert. That fatal error closes and resets the connection, which sets `c.record` to `null`. `_readRecord()` then continues with `c.record.ready = true` and throws `TypeError: Cannot set properties of null (setting…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-8hrf-8g6f-7xwp

  2. Revision 1 · created ·

    Published from ghsa record GHSA-8hrf-8g6f-7xwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119188

Advisory: Forge: Denial of service in TLS record processing via a record interleaved with a fragmented handshake message
IDs: CVE-2026-119188, GHSA-8hrf-8g6f-7xwp
Record: https://patchnext.com/advisories/cve-2026-119188 (revision 2, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-forge 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-forge: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- `npm ls node-forge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-forge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8hrf-8g6f-7xwp (GitHub-reviewed advisory GHSA-8hrf-8g6f-7xwp lists affected ranges: npm node-forge >=0 <=1.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-8hrf-8g6f-7xwp (OSV record GHSA-8hrf-8g6f-7xwp lists affected ranges: npm node-forge >=0 <1.4.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…