Skip to content

← Actionable
Low, CVSS 3.7amended

Forge: ASN.1 OID first arc truncation in asn1.oidToDer

CVE-2026-118775GHSA-4642-5mcj-2rqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-forge 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-118775: 0.31% estimated exploitation activity in the next 30 days; percentile 24.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `asn1.oidToDer()` did not range-check the first two arcs of an OID string, so an OID such as `0.42.840.113549.1.1.1` or `4294977127.18.840.113549.1.1.1` was encoded as the DER of a different OID (here rsaEncryption, `1.2.840.113549.1.1.1`). This is an incomplete fix of CVE-2025-66030. Fixed in node-forge 1.4.1.

Details X.690 section 8.19 encodes the first two arcs of an OID as one subidentifier, `40 * arc1 + arc2`, where the first arc is 0, 1 or 2 and the second arc is at most 39 when the first is 0 or 1. `asn1.oidToDer()` in `lib/asn1.js` computed that value with no range check and wrote it with `putByte()`, which keeps only the low 16 bits. Out-of-range first arcs therefore produced the encoding of a different OID: `0.42.840.113549.1.1.1` gives `40 * 0 + 42 = 42` and `4294977127.18.840.113549.1.1.1` wraps to 42, both the first byte of rsaEncryption. The fix for CVE-2025-66030 (GHSA-65ch-62r8-g69g, node-forge 1.3.2) added a 32-bit check for the later arcs only. A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-4642-5mcj-2rqw

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4642-5mcj-2rqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118775

Advisory: Forge: ASN.1 OID first arc truncation in asn1.oidToDer
IDs: CVE-2026-118775, GHSA-4642-5mcj-2rqw
Record: https://patchnext.com/advisories/cve-2026-118775 (revision 2, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-forge 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-forge: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- `npm ls node-forge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-forge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4642-5mcj-2rqw (GitHub-reviewed advisory GHSA-4642-5mcj-2rqw lists affected ranges: npm node-forge >=0 <=1.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-4642-5mcj-2rqw (OSV record GHSA-4642-5mcj-2rqw lists affected ranges: npm node-forge >=0 <1.4.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…