Skip to content

← Actionable
Medium, CVSS 6.3amended

Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal

CVE-2026-118773GHSA-3g3m-2fjr-6pw4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glob 14.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm glob

    Affected
    >= 9.0.0, < 14.0.2
    Fixed in
    14.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-118773: 0.35% estimated exploitation activity in the next 30 days; percentile 28.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In glob 13.0.6, an aborted async walk rejects or emits an error but continues recursively reading directories in the background. The root cause is that abort branches in src/walker.ts call cb() without returning. As a result, callers that rely on signal or AbortSignal.timeout() to bound glob traversal cost can still incur filesystem I/O and CPU work after the request has already been rejected.

Details This was reproduced on glob v13.0.6 (commit e80cb38ae60d6cbff9e75f39032a994858994d35). The README documents that the signal option cancels the glob walk. However, in src/walker.ts, the following methods call cb() when this.signal?.aborted is true but do not return: - GlobUtil.walkCB() - GlobUtil.walkCB2() - GlobUtil.walkCBSync() - GlobUtil.walkCB2Sync() Example vulnerable pattern: if (this.signal?.aborted) cb() Because execution continues after cb(), the walker still reaches processor.processPatterns(), readdirCB(), and recursive walkCB2() calls. The issue was directly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-3g3m-2fjr-6pw4

  2. Revision 1 · created ·

    Published from ghsa record GHSA-3g3m-2fjr-6pw4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118773

Advisory: Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal
IDs: CVE-2026-118773, GHSA-3g3m-2fjr-6pw4
Record: https://patchnext.com/advisories/cve-2026-118773 (revision 2, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glob 14.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm glob: affected >= 9.0.0, < 14.0.2; fixed in 14.0.2

## Suggested inspection (read-only)
- `npm ls glob --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glob.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3g3m-2fjr-6pw4 (GitHub-reviewed advisory GHSA-3g3m-2fjr-6pw4 lists affected ranges: npm glob >=9.0.0 <=14.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-3g3m-2fjr-6pw4 (OSV record GHSA-3g3m-2fjr-6pw4 lists affected ranges: npm glob >=9.0.0 <14.0.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…