Skip to content

← Actionable
High, CVSS 7.5amended

joi: quadratic-time split in string().email({ multiple: true }) allows denial of service

CVE-2026-118772GHSA-4528-x5fx-h6hg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @hapi/joi

    Affected
    >= 16.0.0, <= 17.1.1
    Fixed in
    no fixed version recorded
  • npm joi

    Affected
    >= 17.1.1, < 17.13.9>= 18.0.0, < 18.3.1
    Fixed in
    18.3.1, 17.13.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-118772: 0.47% estimated exploitation activity in the next 30 days; percentile 40.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `Joi.string().email({ multiple: true })` takes quadratic time to split a value that contains a long run of whitespace. One request with 100 KB of spaces blocks the Node.js event loop for several seconds, which causes a denial of service.

Details When the `multiple` option is set, the `email` rule splits the value into addresses with a regular expression that removes whitespace on each side of the separator: ```js const regex = new RegExp(`\\s*[${options.separator ? escapeRegex(options.separator) : ','}]\\s*`); // ... const emails = options.multiple ? value.split(regex) : [value]; ``` `String.prototype.split` tries a match at each position of the value. At each position inside a whitespace run, the leading `\s*` reads the rest of the run, does not find a separator, and backtracks through all of it. A run of `n` whitespace characters without a separator therefore costs `n²` steps. This applies to the default separator and to all custom `separator` values. The fix lets…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-4528-x5fx-h6hg

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4528-x5fx-h6hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118772

Advisory: joi: quadratic-time split in `string().email({ multiple: true })` allows denial of service
IDs: CVE-2026-118772, GHSA-4528-x5fx-h6hg
Record: https://patchnext.com/advisories/cve-2026-118772 (revision 2, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: joi 18.3.1, 17.13.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hapi/joi: affected >= 16.0.0, <= 17.1.1
- npm joi: affected >= 17.1.1, < 17.13.9; >= 18.0.0, < 18.3.1; fixed in 18.3.1, 17.13.9

## Suggested inspection (read-only)
- `npm ls @hapi/joi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls joi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hapi/joi, joi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4528-x5fx-h6hg (GitHub-reviewed advisory GHSA-4528-x5fx-h6hg lists affected ranges: npm joi >=17.1.1 =18.0.0 =16.0.0 <=17.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-4528-x5fx-h6hg (OSV record GHSA-4528-x5fx-h6hg lists affected ranges: npm joi >=17.1.1 =18.0.0 =16.0.0 <=17.1.1)

Commands are suggestions: review each one before running it.

Loading voting…