Skip to content

← Actionable
Medium, CVSS 6.9amended

minimatch has potential denial of service via globparts amplification

CVE-2026-118764GHSA-g3hv-75wg-m249

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (minimatch 11.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm minimatch

    Affected
    >= 7.0.0, < 11.0.1
    Fixed in
    11.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-118764: 0.29% estimated exploitation activity in the next 30 days; percentile 21.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

minimatch 10.2.6 contains an attacker-controlled pattern amplification in firstPhasePreProcess() when optimizationLevel = 2. researcher: Reid Downing (b1nv0id) files: - src/index.ts: 690-770 - src/index.ts: 780-796 issue: input-controlled growth of globParts during first-phase preprocessing, followed by quadratic second-phase processing. the /../ transformation clones a globparts entry and appends the clone to the same globparts array: this occurs inside a do...while (didSomething) fixpoint loop, allowing generated entries to be processed again. the expanded globparts array is subsequently processed by secondPhasePreProcess(), which performs pairwise comparisons: an attacker who can supply a glob pattern can therefore cause additional pattern entries to be generated during preprocessing, followed by quadratic pairwise processing, resulting in excessive cpu and memory consumption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g3hv-75wg-m249

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g3hv-75wg-m249

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g3hv-75wg-m249

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118764

Advisory: minimatch has potential denial of service via globparts amplification
IDs: CVE-2026-118764, GHSA-g3hv-75wg-m249
Record: https://patchnext.com/advisories/cve-2026-118764 (revision 3, source checked 4 Nov 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: minimatch 11.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm minimatch: affected >= 7.0.0, < 11.0.1; fixed in 11.0.1

## Suggested inspection (read-only)
- `npm ls minimatch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on minimatch.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g3hv-75wg-m249 (GitHub-reviewed advisory GHSA-g3hv-75wg-m249 lists affected ranges: npm minimatch >=0 <11.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-g3hv-75wg-m249 (OSV record GHSA-g3hv-75wg-m249 lists affected ranges: npm minimatch >=0 <11.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g3hv-75wg-m249 (GitHub-reviewed advisory GHSA-g3hv-75wg-m249 lists affected ranges: npm minimatch >=7.0.0 <11.0.1)

Commands are suggestions: review each one before running it.

Loading voting…