Skip to content

← Actionable
High, CVSS 8.4amended

OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client

CVE-2026-118669GHSA-7984-qgvg-3j9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthlib 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI oauthlib

    Affected
    < 4.0.0
    Fixed in
    4.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-118669: 0.31% estimated exploitation activity in the next 30 days; percentile 24.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OAuthlib's token grant handlers can authenticate one client while authorizing the grant type and requested scopes using a different, attacker-supplied `client_id` from the request body. In affected token grant flows, `authenticate_client(request)` sets `request.client` to the authenticated client object, but OAuthlib does not require `request.client_id` to match `request.client.client_id`. If the request body already contains `client_id=...`, OAuthlib keeps that value and passes it to `validate_grant_type()` and `validate_scopes()`. As a result, an authenticated low-privilege confidential client can authenticate as itself, submit another client's `client_id` in the token request body, and cause grant and scope validation to run under that other client identity.

Affected Surface The affected public surface is the OAuth2 token endpoint handling for: - `client_credentials` - `password` / Resource Owner Password Credentials The issue is relevant to OAuthlib provider…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-7984-qgvg-3j9c

  2. Revision 1 · created ·

    Published from ghsa record GHSA-7984-qgvg-3j9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118669

Advisory: OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client
IDs: CVE-2026-118669, GHSA-7984-qgvg-3j9c
Record: https://patchnext.com/advisories/cve-2026-118669 (revision 2, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauthlib 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI oauthlib: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `python -m pip show oauthlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauthlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7984-qgvg-3j9c (GitHub-reviewed advisory GHSA-7984-qgvg-3j9c lists affected ranges: PyPI oauthlib >=0 <4.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-7984-qgvg-3j9c (OSV record GHSA-7984-qgvg-3j9c lists affected ranges: PyPI oauthlib >=0 <4.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…