Skip to content

← Actionable
Medium, CVSS 4.3amended

LangGraph: Unencoded identifiers in LangGraph SDK v3 streaming can redirect authenticated GET requests

CVE-2026-118667GHSA-3fx2-cqw9-xr3c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph 1.2.14; langgraph-sdk 0.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langgraph

    Affected
    >= 1.2.3, < 1.2.14
    Fixed in
    1.2.14
  • PyPI langgraph-sdk

    Affected
    >= 0.4.0, < 0.4.6
    Fixed in
    0.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-118667: 0.39% estimated exploitation activity in the next 30 days; percentile 33.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The LangGraph Python SDK v3 streaming client interpolates caller-supplied `thread_id` and `assistant_id` values into request paths without encoding them at four synchronous and asynchronous call sites. Relative path segments can therefore redirect an authenticated GET request to another path on the same configured server.

Details The affected `get_tree` and `_fetch_state` implementations build request paths from raw identifiers rather than passing each identifier through the SDK's existing `_quote_path_param` helper. HTTP path normalization can collapse values containing relative segments before dispatch while retaining the client's authentication headers. `langgraph-sdk` versions 0.4.0 through 0.4.5 are affected. The v3 stream module is not present in the 0.3.x release line. `RemoteGraph` v3 streaming in `langgraph` 1.2.3 and later is also affected when used with a vulnerable `langgraph-sdk` version. It passes `config["configurable"]["thread_id"]` into…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-3fx2-cqw9-xr3c

  2. Revision 1 · created ·

    Published from ghsa record GHSA-3fx2-cqw9-xr3c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118667

Advisory: LangGraph: Unencoded identifiers in LangGraph SDK v3 streaming can redirect authenticated GET requests
IDs: CVE-2026-118667, GHSA-3fx2-cqw9-xr3c
Record: https://patchnext.com/advisories/cve-2026-118667 (revision 2, source checked 29 Oct 2026, 06:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph 1.2.14; langgraph-sdk 0.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph: affected >= 1.2.3, < 1.2.14; fixed in 1.2.14
- PyPI langgraph-sdk: affected >= 0.4.0, < 0.4.6; fixed in 0.4.6

## Suggested inspection (read-only)
- `python -m pip show langgraph`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langgraph-sdk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph, langgraph-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3fx2-cqw9-xr3c (GitHub-reviewed advisory GHSA-3fx2-cqw9-xr3c lists affected ranges: PyPI langgraph-sdk >=0.4.0 =1.2.3 <1.2.14)
- Verified: https://osv.dev/vulnerability/GHSA-3fx2-cqw9-xr3c (OSV record GHSA-3fx2-cqw9-xr3c lists affected ranges: PyPI langgraph-sdk >=0.4.0 =1.2.3 <1.2.14 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…