GraphQL Tools: Shared legacy executor routes one subscription's results to a different caller
CVE-2026-118666GHSA-mp66-8ww2-pcwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@graphql-tools/executor-legacy-ws 1.1.36), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @graphql-tools/executor-legacy-ws
- Affected
- < 1.1.36
- Fixed in
- 1.1.36
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp66-8ww2-pcwm lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.35
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp66-8ww2-pcwm lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.36 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-118666: 0.34% estimated exploitation activity in the next 30 days; percentile 26.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-tenant subscription data leak in `@graphql-tools/executor-legacy-ws`: a shared `websocket.onmessage` is replaced on every `subscribe()`, and `DATA` frames are delivered without checking the protocol operation id
Report metadata | Field | Value | | --- | --- | | Package | `@graphql-tools/executor-legacy-ws` (npm, `pkg:npm/%40graphql-tools/executor-legacy-ws`) | | Repository | https://github.com/ardatan/graphql-tools | | Component | `buildWSLegacyExecutor` → the returned executor's `subscribe(observer)` / `websocket.onmessage` handler | | Vulnerability class | Cross-tenant data leak (subscription results delivered to the wrong caller) | | Verified against | Source at `b5d1c36ebb8ed3868260ffee5bbcbb423ad5c1f1` (package version 1.1.33); published npm tarball `1.1.33` with matching source at `d304214db06e8a4ce9cb41138f199e3bc6ed36f2`; the same behaviour also reproduces on the current release `1.1.35` | | API surface | Public documented API (`buildWSLegacyExecutor`) | | Affected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-mp66-8ww2-pcwm
- Revision 1 · created ·
Published from ghsa record GHSA-mp66-8ww2-pcwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118666 Advisory: GraphQL Tools: Shared legacy executor routes one subscription's results to a different caller IDs: CVE-2026-118666, GHSA-mp66-8ww2-pcwm Record: https://patchnext.com/advisories/cve-2026-118666 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @graphql-tools/executor-legacy-ws 1.1.36. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @graphql-tools/executor-legacy-ws: affected < 1.1.36; fixed in 1.1.36 ## Suggested inspection (read-only) - `npm ls @graphql-tools/executor-legacy-ws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @graphql-tools/executor-legacy-ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mp66-8ww2-pcwm (GitHub-reviewed advisory GHSA-mp66-8ww2-pcwm lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.35) - Verified: https://osv.dev/vulnerability/GHSA-mp66-8ww2-pcwm (OSV record GHSA-mp66-8ww2-pcwm lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.36 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…