GraphQL Tools: Per-request connection parameters persist into later users' WebSocket authentications
CVE-2026-118665GHSA-434m-5hcj-pxf3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@graphql-tools/executor-legacy-ws 1.1.36), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @graphql-tools/executor-legacy-ws
- Affected
- < 1.1.36
- Fixed in
- 1.1.36
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-434m-5hcj-pxf3 lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.35
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-434m-5hcj-pxf3 lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.36 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-118665: 0.39% estimated exploitation activity in the next 30 days; percentile 32.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Stale authentication state in `@graphql-tools/executor-legacy-ws`: per-request `extensions.connectionParams` persist in executor closure state and are replayed in a later caller's `connection_init`
Report metadata | Field | Value | | --- | --- | | Package | `@graphql-tools/executor-legacy-ws` (npm, `pkg:npm/%40graphql-tools/executor-legacy-ws`) | | Repository | https://github.com/ardatan/graphql-tools | | Component | `buildWSLegacyExecutor` (`packages/executors/legacy-ws/src/index.ts`) | | Vulnerability class | Stale authentication state / credential reuse across requests | | Verified against | Commit `b5d1c36ebb8ed3868260ffee5bbcbb423ad5c1f1`; npm release `1.1.33` installed and exercised. During validation the same behaviour was also observed on the current latest release `1.1.35`, and the unreset closure is still present on `master`. | | API surface | Public documented API (`buildWSLegacyExecutor`, and `request.extensions.connectionParams` on the returned executor) | |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-434m-5hcj-pxf3
- Revision 1 · created ·
Published from ghsa record GHSA-434m-5hcj-pxf3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118665 Advisory: GraphQL Tools: Per-request connection parameters persist into later users' WebSocket authentications IDs: CVE-2026-118665, GHSA-434m-5hcj-pxf3 Record: https://patchnext.com/advisories/cve-2026-118665 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @graphql-tools/executor-legacy-ws 1.1.36. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @graphql-tools/executor-legacy-ws: affected < 1.1.36; fixed in 1.1.36 ## Suggested inspection (read-only) - `npm ls @graphql-tools/executor-legacy-ws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @graphql-tools/executor-legacy-ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-434m-5hcj-pxf3 (GitHub-reviewed advisory GHSA-434m-5hcj-pxf3 lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.35) - Verified: https://osv.dev/vulnerability/GHSA-434m-5hcj-pxf3 (OSV record GHSA-434m-5hcj-pxf3 lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.36 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…