Skip to content

← Actionable
High, CVSS 8.2amended

decode-uri-component vulnerable to denial of service via quadratic replacement of percent-encoded runs

CVE-2026-118664GHSA-qr28-fpjm-wq7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decode-uri-component 0.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-118664: 0.32% estimated exploitation activity in the next 30 days; percentile 24.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `decodeUriComponent()` takes quadratic time on malformed input that has many distinct percent-encoded runs. A single unauthenticated request of about 224 KB can block the Node.js event loop for about 20 seconds. Version 0.5.0, the release that fixed CVE-2026-45822, is affected.

Details When native decodeURIComponent throws, `decodeUriComponent()` falls back to `customDecodeURIComponent` (`index.js:122`). That function: 1. Scans the input for every run of percent-encoded bytes (e.g. `%C3%A5`) and stores each distinct run, with its decoded value, in a lookup table (`index.js:130-144`). 2. Runs one full-string `input.replace(new RegExp(key, 'g'), …)` per table entry (`index.js:154`). With K distinct runs in an input of length L, that's K regex compilations and K full scans of the string, so O(K·L). An attacker controls both K and L, and K grows with L. One malformed sequence such as a trailing `%zz` is enough to force the fallback path. The 0.5.0 fix for CVE-2026-45822…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-qr28-fpjm-wq7f

  2. Revision 1 · created ·

    Published from ghsa record GHSA-qr28-fpjm-wq7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118664

Advisory: decode-uri-component vulnerable to denial of service via quadratic replacement of percent-encoded runs
IDs: CVE-2026-118664, GHSA-qr28-fpjm-wq7f
Record: https://patchnext.com/advisories/cve-2026-118664 (revision 2, source checked 30 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decode-uri-component 0.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm decode-uri-component: affected < 0.5.1; fixed in 0.5.1

## Suggested inspection (read-only)
- `npm ls decode-uri-component --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decode-uri-component.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qr28-fpjm-wq7f (GitHub-reviewed advisory GHSA-qr28-fpjm-wq7f lists affected ranges: npm decode-uri-component >=0 <=0.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-qr28-fpjm-wq7f (OSV record GHSA-qr28-fpjm-wq7f lists affected ranges: npm decode-uri-component >=0 <0.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…