Echo has a Static Middleware Double-Unescape Path Traversal
CVE-2026-118655GHSA-xwq5-6cqp-vx96
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/labstack/echo/v4 4.15.3; github.com/labstack/echo/v5 5.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/labstack/echo/v4
- Affected
- < 4.15.3
- Fixed in
- 4.15.3
Go github.com/labstack/echo/v5
- Affected
- < 5.2.0
- Fixed in
- 5.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xwq5-6cqp-vx96 lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.15.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xwq5-6cqp-vx96 lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.15.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-118655: 0.30% estimated exploitation activity in the next 30 days; percentile 23.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Commit a9ede66a (PR #3006, issue #2599) silently fixed a path traversal vulnerability in the Echo web framework's static file middleware.
Vulnerability The static middleware double-unescaped URL paths. Go's net/http already decodes Request.URL.Path, but middleware/static.go unconditionally called url.PathUnescape() again: ```go // BEFORE (vulnerable) pathUnescape := true ``` This reassembled path traversal sequences from double-encoded input. An attacker could send GET /%2e%2e%2fsecret.txt or /..%252fsecret.txt and the double-unescape would produce ../secret.txt.
Fix ```go // AFTER (fixed) pathUnescape := false ``` The commit's test TestStatic_percentEncodedTraversalIsBlocked explicitly verifies traversal vectors are blocked.
Impact Arbitrary file read from server filesystem via percent-encoded path traversal.
References - Fix: https://github.com/labstack/echo/commit/a9ede66a - Issue: https://github.com/labstack/echo/issues/2599 - PR:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-xwq5-6cqp-vx96
- Revision 1 · created ·
Published from ghsa record GHSA-xwq5-6cqp-vx96
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118655 Advisory: Echo has a Static Middleware Double-Unescape Path Traversal IDs: CVE-2026-118655, GHSA-xwq5-6cqp-vx96 Record: https://patchnext.com/advisories/cve-2026-118655 (revision 2, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/labstack/echo/v4 4.15.3; github.com/labstack/echo/v5 5.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/labstack/echo/v4: affected < 4.15.3; fixed in 4.15.3 - Go github.com/labstack/echo/v5: affected < 5.2.0; fixed in 5.2.0 ## Suggested inspection (read-only) - Go github.com/labstack/echo/v4: check the installed version with your package manager. - Go github.com/labstack/echo/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/labstack/echo/v4, github.com/labstack/echo/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xwq5-6cqp-vx96 (GitHub-reviewed advisory GHSA-xwq5-6cqp-vx96 lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.15.3) - Verified: https://osv.dev/vulnerability/GHSA-xwq5-6cqp-vx96 (OSV record GHSA-xwq5-6cqp-vx96 lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.15.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…