Echo static file middleware route protection bypass via encoded dot-dot traversal
CVE-2026-118654GHSA-3pmx-cf9f-34xr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/labstack/echo/v4 4.16.0; github.com/labstack/echo/v5 5.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/labstack/echo/v4
- Affected
- < 4.16.0
- Fixed in
- 4.16.0
Go github.com/labstack/echo/v5
- Affected
- < 5.4.0
- Fixed in
- 5.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3pmx-cf9f-34xr lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3pmx-cf9f-34xr lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-118654: 0.35% estimated exploitation activity in the next 30 days; percentile 28.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Echo v5.2.0 contains a bypass of the fix for GHSA-vfp3-v2gw-7wfq. The fix rejects encoded path separators such as `%2F` and `%5C` before static file path unescaping, but two traversal forms still bypass route-level middleware protections for static files. The primary bypass uses encoded dot-dot segments. A request such as `/public/%2E%2E/admin/secret.txt` passes the encoded-separator guard, is unescaped to `public/../admin/secret.txt`, then `path.Clean` resolves it to `admin/secret.txt`. If `/admin/*` is protected by middleware but the static filesystem is mounted at `/`, the protected file is returned through the public static route. A second bypass exists when `UseEscapedPathForMatching=true`. In that mode, the router normalizes encoded separators before the static handler checks the wildcard. The handler receives a decoded wildcard with no `%` characters, so the encoded-separator guard does not run on the original encoded path.
Impact An unauthenticated attacker can…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-3pmx-cf9f-34xr
- Revision 1 · created ·
Published from ghsa record GHSA-3pmx-cf9f-34xr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118654 Advisory: Echo static file middleware route protection bypass via encoded dot-dot traversal IDs: CVE-2026-118654, GHSA-3pmx-cf9f-34xr Record: https://patchnext.com/advisories/cve-2026-118654 (revision 2, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/labstack/echo/v4 4.16.0; github.com/labstack/echo/v5 5.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/labstack/echo/v4: affected < 4.16.0; fixed in 4.16.0 - Go github.com/labstack/echo/v5: affected < 5.4.0; fixed in 5.4.0 ## Suggested inspection (read-only) - Go github.com/labstack/echo/v4: check the installed version with your package manager. - Go github.com/labstack/echo/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/labstack/echo/v4, github.com/labstack/echo/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3pmx-cf9f-34xr (GitHub-reviewed advisory GHSA-3pmx-cf9f-34xr lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0) - Verified: https://osv.dev/vulnerability/GHSA-3pmx-cf9f-34xr (OSV record GHSA-3pmx-cf9f-34xr lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…