Echo vulnerable to Reflected Cross-Site Scripting (XSS) via unsanitized JSONP callback in Context.JSONP / Context.JSONPBlob
CVE-2026-118652GHSA-h9g5-28mm-hx3g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/labstack/echo/v4 4.16.0; github.com/labstack/echo/v5 5.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/labstack/echo/v4
- Affected
- < 4.16.0
- Fixed in
- 4.16.0
Go github.com/labstack/echo/v5
- Affected
- < 5.4.0
- Fixed in
- 5.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9g5-28mm-hx3g lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h9g5-28mm-hx3g lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-118652: 0.24% estimated exploitation activity in the next 30 days; percentile 15.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The `Context.JSONP`, `Context.JSONPBlob`, and internal `jsonPBlob` helper in `context.go` directly concatenate the caller-supplied `callback` parameter into a JavaScript response without any validation, escaping, or allow-listing. This creates a high-impact reflected XSS that can be triggered by any route passing attacker-controlled data (query string, form, header, path param, etc.) into the callback. Present in current master and v5.1.0 (latest release).
Vulnerable Code (verbatim) ```go func (c *Context) jsonPBlob(code int, callback string, i any) (err error) { c.writeContentType(MIMEApplicationJavaScriptCharsetUTF8) c.response.WriteHeader(code) if _, err = c.response.Write([]byte(callback + "(")); err != nil { return } if err = c.echo.JSONSerializer.Serialize(c, i, ""); err != nil { return } if _, err = c.response.Write([]byte(");")); err != nil { return } return } func (c *Context) JSONP(code int, callback string, i any) (err error) { return…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-h9g5-28mm-hx3g
- Revision 1 · created ·
Published from ghsa record GHSA-h9g5-28mm-hx3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118652 Advisory: Echo vulnerable to Reflected Cross-Site Scripting (XSS) via unsanitized JSONP callback in Context.JSONP / Context.JSONPBlob IDs: CVE-2026-118652, GHSA-h9g5-28mm-hx3g Record: https://patchnext.com/advisories/cve-2026-118652 (revision 2, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/labstack/echo/v4 4.16.0; github.com/labstack/echo/v5 5.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/labstack/echo/v4: affected < 4.16.0; fixed in 4.16.0 - Go github.com/labstack/echo/v5: affected < 5.4.0; fixed in 5.4.0 ## Suggested inspection (read-only) - Go github.com/labstack/echo/v4: check the installed version with your package manager. - Go github.com/labstack/echo/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/labstack/echo/v4, github.com/labstack/echo/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h9g5-28mm-hx3g (GitHub-reviewed advisory GHSA-h9g5-28mm-hx3g lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0) - Verified: https://osv.dev/vulnerability/GHSA-h9g5-28mm-hx3g (OSV record GHSA-h9g5-28mm-hx3g lists affected ranges: Go github.com/labstack/echo/v5 >=0 =0 <4.16.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…