Vue I18n: escapeParameter does not escape named values when the same call also passes a list
CVE-2026-118256GHSA-8rc2-428q-7ww3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@intlify/vue-i18n-core 12.0.0-alpha.5, 11.4.14; vue-i18n 12.0.0-alpha.5, 11.4.14; petite-vue-i18n 12.0.0-alpha.5, 11.4.14; @intlify/core-base 12.0.0-alpha.5, 11.4.14; @intlify/core 12.0.0-alpha.5, 11.4.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 9.2.0-alpha.7, < 11.4.14>= 12.0.0-alpha.1, < 12.0.0-alpha.5
- Fixed in
- 12.0.0-alpha.5, 11.4.14
npm vue-i18n
- Affected
- >= 9.0.0-beta.5, < 11.4.14>= 12.0.0-alpha.1, < 12.0.0-alpha.5
- Fixed in
- 12.0.0-alpha.5, 11.4.14
npm petite-vue-i18n
- Affected
- >= 9.2.0-alpha.7, < 11.4.14>= 12.0.0-alpha.1, < 12.0.0-alpha.5
- Fixed in
- 12.0.0-alpha.5, 11.4.14
- Affected
- >= 9.0.0-beta.12, < 11.4.14>= 12.0.0-alpha.1, < 12.0.0-alpha.5
- Fixed in
- 12.0.0-alpha.5, 11.4.14
npm @intlify/core
- Affected
- >= 9.0.0-beta.10, < 11.4.14>= 12.0.0-alpha.1, < 12.0.0-alpha.5
- Fixed in
- 12.0.0-alpha.5, 11.4.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8rc2-428q-7ww3 lists affected ranges: npm vue-i18n >=9.0.0-beta.5 =12.0.0-alpha.1 =9.0.0-beta.10 =12.0.0-alpha.1 =9.0.0-beta.12 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 <12.0.0-alpha.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8rc2-428q-7ww3 lists affected ranges: npm vue-i18n >=9.0.0-beta.5 =12.0.0-alpha.1 =9.0.0-beta.10 =12.0.0-alpha.1 =9.0.0-beta.12 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 =9.2.0-alpha.7 <11.4.14 (fixed),…
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2026-118256: 0.48% estimated exploitation activity in the next 30 days; percentile 41.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When `escapeParameter` is enabled (`escapeParameterHtml` in the Legacy API), Vue I18n escapes the interpolation parameters before formatting a message. `escapeParams()` escapes either the list values or the named values, but not both: the two branches are joined by `else`. When a single call passes both, for example `t(key, ['...'], { named: { ... } })`, the named values reach the message without being escaped.
Details `escapeParams()` in `packages/core-base/src/translate.ts` (v11.4.13): ```ts function escapeParams(options: TranslateOptions) { if (isArray(options.list)) { options.list = options.list.map(item => (isString(item) ? escapeHtml(item) : item)) } else if (isObject(options.named)) { // ...escapes the named values } } ``` `t(key, list, options)` is a public overload, and `TranslateOptions` has a `named` field, so a call can carry both. The list is checked first, and the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-8rc2-428q-7ww3
- Revision 1 · created ·
Published from ghsa record GHSA-8rc2-428q-7ww3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118256 Advisory: Vue I18n: `escapeParameter` does not escape named values when the same call also passes a list IDs: CVE-2026-118256, GHSA-8rc2-428q-7ww3 Record: https://patchnext.com/advisories/cve-2026-118256 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @intlify/vue-i18n-core 12.0.0-alpha.5, 11.4.14; vue-i18n 12.0.0-alpha.5, 11.4.14; petite-vue-i18n 12.0.0-alpha.5, 11.4.14; @intlify/core-base 12.0.0-alpha.5, 11.4.14; @intlify/core 12.0.0-alpha.5, 11.4.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @intlify/vue-i18n-core: affected >= 9.2.0-alpha.7, < 11.4.14; >= 12.0.0-alpha.1, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5, 11.4.14 - npm vue-i18n: affected >= 9.0.0-beta.5, < 11.4.14; >= 12.0.0-alpha.1, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5, 11.4.14 - npm petite-vue-i18n: affected >= 9.2.0-alpha.7, < 11.4.14; >= 12.0.0-alpha.1, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5, 11.4.14 - npm @intlify/core-base: affected >= 9.0.0-beta.12, < 11.4.14; >= 12.0.0-alpha.1, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5, 11.4.14 - npm @intlify/core: affected >= 9.0.0-beta.10, < 11.4.14; >= 12.0.0-alpha.1, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5, 11.4.14 ## Suggested inspection (read-only) - `npm ls @intlify/vue-i18n-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls petite-vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @intlify/core-base --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @intlify/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @intlify/vue-i18n-core, vue-i18n, petite-vue-i18n, @intlify/core-base, @intlify/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8rc2-428q-7ww3 (GitHub-reviewed advisory GHSA-8rc2-428q-7ww3 lists affected ranges: npm vue-i18n >=9.0.0-beta.5 =12.0.0-alpha.1 =9.0.0-beta.10 =12.0.0-alpha.1 =9.0.0-beta.12 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 <12.0.0-alpha.5) - Verified: https://osv.dev/vulnerability/GHSA-8rc2-428q-7ww3 (OSV record GHSA-8rc2-428q-7ww3 lists affected ranges: npm vue-i18n >=9.0.0-beta.5 =12.0.0-alpha.1 =9.0.0-beta.10 =12.0.0-alpha.1 =9.0.0-beta.12 =12.0.0-alpha.1 =9.2.0-alpha.7 =12.0.0-alpha.1 =9.2.0-alpha.7 <11.4.14 (fixed),…) Commands are suggestions: review each one before running it.
Loading voting…