Skip to content

← Actionable
High, CVSS 8.4amended

Highcharts Grid: javascript: URL in credits.href runs script on click

CVE-2026-118255GHSA-6hgp-fmhr-mrg4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/grid-pro 3.2.0; @highcharts/dashboards 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-118255: 0.35% estimated exploitation activity in the next 30 days; percentile 28.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who controls the Grid configuration can set `credits.href` to a `javascript:` URL. The value is not validated against an allowed-scheme list before it is applied to the credits link, so activating that link runs attacker-supplied script in the origin of the page hosting the Grid. Exploitation requires that untrusted data reach the Grid configuration and that a user activate the credits link. Script running this way has the same access to page data, storage and session state as the hosting application.

Workarounds Paste in after the Grid Pro module is imported, before a Grid is created. ```javascript const { AST } = Grid; function sanitize(options) { const credits = options && options.credits; if (credits && typeof credits.href === 'string') { const filtered = AST.filterUserAttributes({ href: credits.href }); if (!filtered.href) { delete credits.href; } } return options; } // Both Grid.grid() and grid.update() funnel through loadUserOptions, so one // hook…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6hgp-fmhr-mrg4

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6hgp-fmhr-mrg4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118255

Advisory: Highcharts Grid: `javascript:` URL in credits.href runs script on click
IDs: CVE-2026-118255, GHSA-6hgp-fmhr-mrg4
Record: https://patchnext.com/advisories/cve-2026-118255 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @highcharts/grid-pro 3.2.0; @highcharts/dashboards 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @highcharts/grid-pro: affected >= 2.0.0, < 3.2.0; fixed in 3.2.0
- npm @highcharts/dashboards: affected >= 3.2.0, < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls @highcharts/grid-pro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @highcharts/dashboards --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @highcharts/grid-pro, @highcharts/dashboards.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6hgp-fmhr-mrg4 (GitHub-reviewed advisory GHSA-6hgp-fmhr-mrg4 lists affected ranges: npm @highcharts/dashboards >=3.2.0 =2.0.0 <=3.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-6hgp-fmhr-mrg4 (OSV record GHSA-6hgp-fmhr-mrg4 lists affected ranges: npm @highcharts/dashboards >=3.2.0 =2.0.0 <3.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…