Highcharts Dashboards parses fullscreen labels as HTML
CVE-2026-118253GHSA-58g7-7f52-h92c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/dashboards 4.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.0.0, < 4.2.3
- Fixed in
- 4.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-58g7-7f52-h92c lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-58g7-7f52-h92c lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-118253: 0.42% estimated exploitation activity in the next 30 days; percentile 36.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The edit mode fullscreen labels are parsed as HTML when the corresponding control is rendered. An attacker who controls the Dashboards language options can supply markup carrying event handlers, which then execute in the origin of the page hosting the dashboard. Exploitation requires that untrusted data reach the Dashboards language configuration and that the affected control be rendered. Script running this way has the same access to page data, storage and session state as the hosting application.
Workarounds Until you can upgrade, replace `Fullscreen.prototype.setButtonText` atapplication startup. The replacement is the original method with `textContent` in place of `innerHTML`.
If you install Dashboards from npm Import the module once, before any board is created. ```js import Fullscreen from '@highcharts/dashboards/es-modules/Dashboards/EditMode/Fullscreen.js'; Fullscreen.prototype.setButtonText = function () { const editMode = this.board.editMode, button =…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-58g7-7f52-h92c
- Revision 1 · created ·
Published from ghsa record GHSA-58g7-7f52-h92c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118253 Advisory: Highcharts Dashboards parses fullscreen labels as HTML IDs: CVE-2026-118253, GHSA-58g7-7f52-h92c Record: https://patchnext.com/advisories/cve-2026-118253 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @highcharts/dashboards 4.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @highcharts/dashboards: affected >= 1.0.0, < 4.2.3; fixed in 4.2.3 ## Suggested inspection (read-only) - `npm ls @highcharts/dashboards --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @highcharts/dashboards. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-58g7-7f52-h92c (GitHub-reviewed advisory GHSA-58g7-7f52-h92c lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3) - Verified: https://osv.dev/vulnerability/GHSA-58g7-7f52-h92c (OSV record GHSA-58g7-7f52-h92c lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…