Highcharts Dashboards parses sidebar component labels as HTML
CVE-2026-118252GHSA-rcqf-f6h2-ccg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/dashboards 4.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.0.0, < 4.2.3
- Fixed in
- 4.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcqf-f6h2-ccg9 lists affected ranges: npm @highcharts/dashboards >=1.0.0 <=4.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcqf-f6h2-ccg9 lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-118252: 0.42% estimated exploitation activity in the next 30 days; percentile 36.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The component language strings shown in the edit mode sidebar are parsed as HTML rather than inserted as text. An attacker who controls those language options can supply markup carrying event handlers, which execute in the origin of the page hosting the dashboard once the sidebar renders the affected labels. Exploitation requires that untrusted data reach the Dashboards language configuration and that a user open the edit mode sidebar.
Workarounds Until you can upgrade, patch `EditMode` once at application startup. The hook runs before the sidebar is built, so the labels are already harmless by the time they are rendered. Assigning a string to `textContent` and reading back `innerHTML` turns any markup into literal text, which is exactly what the fixed version renders. After importing the module, use this code snipped once, before any board is created. ```js { const EditMode = window.Dashboards?.EditMode; const escapeHTML = (text) => text .replace(/&/g, '&')…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-rcqf-f6h2-ccg9
- Revision 1 · created ·
Published from ghsa record GHSA-rcqf-f6h2-ccg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118252 Advisory: Highcharts Dashboards parses sidebar component labels as HTML IDs: CVE-2026-118252, GHSA-rcqf-f6h2-ccg9 Record: https://patchnext.com/advisories/cve-2026-118252 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @highcharts/dashboards 4.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @highcharts/dashboards: affected >= 1.0.0, < 4.2.3; fixed in 4.2.3 ## Suggested inspection (read-only) - `npm ls @highcharts/dashboards --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @highcharts/dashboards. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rcqf-f6h2-ccg9 (GitHub-reviewed advisory GHSA-rcqf-f6h2-ccg9 lists affected ranges: npm @highcharts/dashboards >=1.0.0 <=4.2.2) - Verified: https://osv.dev/vulnerability/GHSA-rcqf-f6h2-ccg9 (OSV record GHSA-rcqf-f6h2-ccg9 lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…