Highcharts: javascript: URL in credits.href runs script on click
CVE-2026-118251GHSA-5793-x2q3-c3q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 13.1.0, 12.6.1, 11.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm highcharts
- Affected
- < 11.4.9>= 12.0.0, < 12.6.1>= 13.0.0, < 13.1.0
- Fixed in
- 11.4.9, 13.1.0, 12.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5793-x2q3-c3q7 lists affected ranges: npm highcharts >=0 =12.0.0 =13.0.0 <=13.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5793-x2q3-c3q7 lists affected ranges: npm highcharts >=0 =12.0.0 =13.0.0 <13.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-118251: 0.43% estimated exploitation activity in the next 30 days; percentile 37.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A `credits.href` value beginning with `javascript:` is assigned to the window location when the credits label is clicked, without being checked against an allowed-scheme list. An attacker who controls the chart configuration can therefore run script in the origin of the page hosting the chart. Exploitation requires that untrusted data reach the chart configuration and that a user click the credits label. Charts built with Highcharts Stock, Maps and Gantt are included, since those ship from the same package as Core.
Workarounds Drop-in fix - for any versions affected (5.0.0-13.0.2). Add the below IIFE to run after Highcharts is loaded, but before a chart is created. ```js !function(t){if(t&&t.Chart&&!t.Chart.prototype.creditsHrefPatched){var r=t.Chart.prototype,e=r.addCredits;r.addCredits=function(n){var o=t.merge(!0,this.options.credits,n);return o&&o.href&&!c(o.href)&&delete o.href,e.call(this,o)},r.creditsHrefPatched=!0}function c(r){var…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-5793-x2q3-c3q7
- Revision 1 · created ·
Published from ghsa record GHSA-5793-x2q3-c3q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118251 Advisory: Highcharts: `javascript:` URL in credits.href runs script on click IDs: CVE-2026-118251, GHSA-5793-x2q3-c3q7 Record: https://patchnext.com/advisories/cve-2026-118251 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: highcharts 13.1.0, 12.6.1, 11.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm highcharts: affected < 11.4.9; >= 12.0.0, < 12.6.1; >= 13.0.0, < 13.1.0; fixed in 11.4.9, 13.1.0, 12.6.1 ## Suggested inspection (read-only) - `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on highcharts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5793-x2q3-c3q7 (GitHub-reviewed advisory GHSA-5793-x2q3-c3q7 lists affected ranges: npm highcharts >=0 =12.0.0 =13.0.0 <=13.0.2) - Verified: https://osv.dev/vulnerability/GHSA-5793-x2q3-c3q7 (OSV record GHSA-5793-x2q3-c3q7 lists affected ranges: npm highcharts >=0 =12.0.0 =13.0.0 <13.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…