Highcharts Core: breadcrumbs.style keys become SVG event-handler attributes
CVE-2026-118246GHSA-35rr-xwfh-x789
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 13.1.0, 12.6.1, 11.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm highcharts
- Affected
- >= 10.0.0, < 11.4.9>= 12.0.0, < 12.6.1>= 13.0.0, < 13.1.0
- Fixed in
- 11.4.9, 13.1.0, 12.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35rr-xwfh-x789 lists affected ranges: npm highcharts >=10.0.0 =12.0.0 =13.0.0 <=13.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35rr-xwfh-x789 lists affected ranges: npm highcharts >=10.0.0 =12.0.0 =13.0.0 <13.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-118246: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The breadcrumbs `style` option is applied to the breadcrumb button as SVG attributes rather than as CSS, and the attribute names are not filtered. An attacker who controls the chart configuration can supply keys under `breadcrumbs.style` that name event handlers, and those keys become live handlers on the breadcrumb button, so the attacker's script runs in the origin of the page hosting the chart. The option is reached through `drilldown.breadcrumbs`, `navigation.breadcrumbs` and the `breadcrumbs` option of the treemap, sunburst and treegraph series. Exploitation requires that untrusted data reach the chart configuration and that a user drill down, or traverse into a level of a hierarchical series, so that the breadcrumbs render, and then hover over or activate the breadcrumb button. Charts rendered in styled mode do not apply the option and are not affected. Charts built with Highcharts Stock, Maps and Gantt are included, since those ship from the same package as Core.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-35rr-xwfh-x789
- Revision 1 · created ·
Published from ghsa record GHSA-35rr-xwfh-x789
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118246 Advisory: Highcharts Core: `breadcrumbs.style` keys become SVG event-handler attributes IDs: CVE-2026-118246, GHSA-35rr-xwfh-x789 Record: https://patchnext.com/advisories/cve-2026-118246 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: highcharts 13.1.0, 12.6.1, 11.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm highcharts: affected >= 10.0.0, < 11.4.9; >= 12.0.0, < 12.6.1; >= 13.0.0, < 13.1.0; fixed in 11.4.9, 13.1.0, 12.6.1 ## Suggested inspection (read-only) - `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on highcharts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-35rr-xwfh-x789 (GitHub-reviewed advisory GHSA-35rr-xwfh-x789 lists affected ranges: npm highcharts >=10.0.0 =12.0.0 =13.0.0 <=13.0.2) - Verified: https://osv.dev/vulnerability/GHSA-35rr-xwfh-x789 (OSV record GHSA-35rr-xwfh-x789 lists affected ranges: npm highcharts >=10.0.0 =12.0.0 =13.0.0 <13.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…