Skip to content

← Actionable
High, CVSS 8.6amended

Highcharts Dashboards: chartConstructor is an unchecked lookup into the Highcharts namespace

CVE-2026-118245GHSA-grj7-r4jv-pw9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/dashboards 4.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-118245: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Highcharts component uses the value of `chartConstructor` to select a function from the Highcharts namespace and invokes it with the component's container element and its `chartOptions`, without checking the value against the supported chart constructors. An attacker who controls the dashboard configuration can therefore name any other public member of that namespace; utility functions in that namespace copy the supplied options onto the container element as properties or attributes, so markup and event handlers carried in `chartOptions` land in the page and run in the origin of the page hosting the dashboard. Exploitation requires that untrusted data reach the Dashboards component configuration. No user interaction is required beyond rendering the board.

Workarounds If your board configuration comes from a source you do not fully control, paste this snippet right after importing libraries: ```ts (function () { const HighchartsComponent = Dashboards &&…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-grj7-r4jv-pw9j

  2. Revision 1 · created ·

    Published from ghsa record GHSA-grj7-r4jv-pw9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118245

Advisory: Highcharts Dashboards: `chartConstructor` is an unchecked lookup into the Highcharts namespace
IDs: CVE-2026-118245, GHSA-grj7-r4jv-pw9j
Record: https://patchnext.com/advisories/cve-2026-118245 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @highcharts/dashboards 4.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @highcharts/dashboards: affected >= 1.0.0, < 4.2.2; fixed in 4.2.2

## Suggested inspection (read-only)
- `npm ls @highcharts/dashboards --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @highcharts/dashboards.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-grj7-r4jv-pw9j (GitHub-reviewed advisory GHSA-grj7-r4jv-pw9j lists affected ranges: npm @highcharts/dashboards >=1.0.0 <=4.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-grj7-r4jv-pw9j (OSV record GHSA-grj7-r4jv-pw9j lists affected ranges: npm @highcharts/dashboards >=1.0.0 <4.2.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…