Skip to content

← Actionable
High, CVSS 7.2amended

Highcharts Core: HTML text parsing falls back to unfiltered innerHTML during printing

CVE-2026-118244GHSA-65hg-cf3f-5m39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 13.1.0, 12.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm highcharts

    Affected
    >= 12.0.0, < 12.6.1>= 13.0.0, < 13.1.0
    Fixed in
    13.1.0, 12.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-118244: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When the HTML text parser cannot obtain a document from `DOMParser` because the call throws, it falls back to assigning the raw markup to the `innerHTML` of an element created in the hosting document, and the allow-list is applied only to the resulting DOM afterwards. In Chromium the Trusted Types policy callback that the parser uses throws while a `beforeprint` handler is running, so if the hosting page re-renders the chart from a `beforeprint` handler, every HTML-rendered text option parsed at that moment, such as `useHTML` titles, axis labels and data labels or text set by responsive rules, is inserted unsanitized, and event handlers embedded in that markup run in the origin of the page hosting the chart. Exploitation requires that untrusted data reach the chart configuration, that the hosting page update the chart from a `beforeprint` handler in Chromium, and that printing be started, which the print item of the exporting menu does on its own. Charts built with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-65hg-cf3f-5m39

  2. Revision 1 · created ·

    Published from ghsa record GHSA-65hg-cf3f-5m39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118244

Advisory: Highcharts Core: HTML text parsing falls back to unfiltered `innerHTML` during printing
IDs: CVE-2026-118244, GHSA-65hg-cf3f-5m39
Record: https://patchnext.com/advisories/cve-2026-118244 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: highcharts 13.1.0, 12.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm highcharts: affected >= 12.0.0, < 12.6.1; >= 13.0.0, < 13.1.0; fixed in 13.1.0, 12.6.1

## Suggested inspection (read-only)
- `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on highcharts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65hg-cf3f-5m39 (GitHub-reviewed advisory GHSA-65hg-cf3f-5m39 lists affected ranges: npm highcharts >=12.0.0 =13.0.0 <=13.0.2)
- Verified: https://osv.dev/vulnerability/GHSA-65hg-cf3f-5m39 (OSV record GHSA-65hg-cf3f-5m39 lists affected ranges: npm highcharts >=12.0.0 =13.0.0 <13.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…