Skip to content

← Actionable
High, CVSS 8.5amended

Highcharts Grid: custom icon definition objects written with raw setAttribute on

CVE-2026-118242GHSA-6g3c-p4fg-xv47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/grid-pro 3.2.0; @highcharts/grid-lite 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-118242: 0.30% estimated exploitation activity in the next 30 days; percentile 23.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A custom icon supplied under `rendering.icons` as an icon definition object is built by creating an SVG path for each of its child entries and setting every key of that entry as an attribute of the path, without filtering the attribute names; only the string form of the option is passed through the markup allow-list. An attacker who controls the Grid configuration can therefore supply child entries whose keys name event handlers, and those handlers execute in the origin of the page hosting the Grid. Custom icons take precedence over the built-in ones, so the attacker can replace icons that render without any further configuration, such as the sort icon shown in every column header by default and the pagination controls where pagination is enabled, and does not need any reference to a custom icon name. Exploitation requires that untrusted data reach the Grid configuration and that a user hover over or activate an affected icon.

Workarounds If your Grid configuration…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6g3c-p4fg-xv47

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6g3c-p4fg-xv47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-118242

Advisory: Highcharts Grid: custom icon definition objects written with raw `setAttribute` on ` `
IDs: CVE-2026-118242, GHSA-6g3c-p4fg-xv47
Record: https://patchnext.com/advisories/cve-2026-118242 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @highcharts/grid-pro 3.2.0; @highcharts/grid-lite 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @highcharts/grid-pro: affected >= 2.3.0, < 3.2.0; fixed in 3.2.0
- npm @highcharts/grid-lite: affected >= 2.3.0, < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `npm ls @highcharts/grid-pro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @highcharts/grid-lite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @highcharts/grid-pro, @highcharts/grid-lite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6g3c-p4fg-xv47 (GitHub-reviewed advisory GHSA-6g3c-p4fg-xv47 lists affected ranges: npm @highcharts/grid-lite >=2.3.0 =2.3.0 <=3.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-6g3c-p4fg-xv47 (OSV record GHSA-6g3c-p4fg-xv47 lists affected ranges: npm @highcharts/grid-lite >=2.3.0 =2.3.0 <3.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…