Skip to content

← Actionable
Critical, CVSS 9.3amended

Electrum: Malicious server can replace a just-broadcast tx and try to trick user into RBF-ing it

CVE-2026-117601GHSA-6jp4-8v48-cc5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electrum 4.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI electrum

    Affected
    < 4.8.3
    Fixed in
    4.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-117601: 0.18% estimated exploitation activity in the next 30 days; percentile 7.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The main Electrum server the client connects to is trusted with mempool ("unconfirmed") transactions. This is documented design. [0] However now someone figured out a way to practically exploit it: - when the client broadcasts a new tx1, a malicious server can swallow it, - and update the client's history with a conflicting (invalid) tx2 that replaces the outputs with the attacker's output address. - Tx2 has invalid signatures, but this is not checked (due to light client design). - The wallet will display tx2 as an unconfirmed transaction - tx1 will not be displayed. - If the client then manually RBF fee-bumps tx2, the client will sign it with a higher fee, and hence pay the attacker.

Fixes Commit 90fe30822 contains the fix [1], included in version 4.8.3. The client now verifies the signatures of `wallet.is_mine` inputs for mempool txs (before adding them to its local history). Users…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6jp4-8v48-cc5v

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6jp4-8v48-cc5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-117601

Advisory: Electrum: Malicious server can replace a just-broadcast tx and try to trick user into RBF-ing it
IDs: CVE-2026-117601, GHSA-6jp4-8v48-cc5v
Record: https://patchnext.com/advisories/cve-2026-117601 (revision 2, source checked 29 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electrum 4.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI electrum: affected < 4.8.3; fixed in 4.8.3

## Suggested inspection (read-only)
- `python -m pip show electrum`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electrum.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6jp4-8v48-cc5v (OSV record GHSA-6jp4-8v48-cc5v lists affected ranges: PyPI electrum >=0 <4.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6jp4-8v48-cc5v (GitHub-reviewed advisory GHSA-6jp4-8v48-cc5v lists affected ranges: PyPI electrum >=0 <4.8.3)

Commands are suggestions: review each one before running it.

Loading voting…